Pico Enviro + pack Problem


Purchased a Pico Enivro + Pack recently and performed tests that appeared to work
Today I received the particulate sensor module and when I run the two examples that utilize the particulate module I get an error message as follows:

ImportError: no module named ‘pms5003’

I have tried two particulate sensors with similar results.

As far as I can see Enviro+ should have installed the module for the pms5003. Is your UART enabled? Try running sudo raspi-config and look in Interfaces.

If not, you could try installing the module from here: GitHub - pimoroni/pms5003-python: Python library for the PMS5003 particulate sensor


After spending more time on this problem, I discovered that I didn’t install the PM drivers.

So, after installing the PM drivers, I can get the particulate sensor to work will all examples except one example program, i.e. “envir_all.py” The “envir_all.py” program is supposed to display particulate data but doesn"t show any PM data but shows other sensor info.
what is happening with program, doesn"t appear to work correctly?
please help

I’m a bit confused? Just to confirm Raspberry Pi Enviro+ or Pi Pico Enviro+?

Experiments with Pico enviro + pack with PM sensor module

Ok, I would have thought that the pimoroni-picow_enviro-1.19.7-micropython.uf2 would have all the necessary libraries included?