Pirate Radio pops but no music?


#1

It was working fine, then after turning it on the other day I got the Vu meter flash, pops from the speakers, but no music? Changed channels and just got the speaker pops. Same deal if I play pause, etc. Did a complete reinstall with the one liner in Jessie, same deal. Did another reinstall, this time I just ran the pHat beat one line installer. I hear the speaker pops etc. Ran the speaker test and get
"Playback open error: -16, Device or resource busy"
Pi Zero W .


Phatbeat installation issues
#2

You’ll need to stop Pulse for speaker-test to run. Try:

sudo systemctl stop pulseaudio

Then run speaker-test again and see if you hear anything.


#3

Ok that worked, and I heard front left front right. VU meter worked Ok too. So what happened to my VLC Radio install? It no longer works even with the default playlist? I don’t have it installed at the moment. I thought it might be what was stopping my speaker test from working so I just installed the pHat Beat stuff.


#4

No mention of having to do that here by the way, https://learn.pimoroni.com/tutorial/sandyj/getting-started-with-phat-beat


#5

That’s quite possibly because I changed the installer to include PulseAudio, to prevent popping and other issues :( Always something going wrong. D’oh!

I’m not sure what might have caused VLC to stop working, but you may be able to find some information by viewing:

cat /var/run/vlcd/vlcd.log

It could be some kind of network issue, perhaps?


#6

Ok, I’m leaning to wards network issue too. Now that I know my pHat Beat works. I’ll have to install vlc radio (pirate radio) and go from there. I have had silence on boot up in the past, bad steam or something for that channel. Usually changing channels or hitting play pause fixes it. Thanks for the help so far.


#7

Maybe you can make something out of this? I can’t.

– logger module started –
core error: no suitable interface module
core error: interface “globalhotkeys,none” initialization failed
lua: Listening on host “0.0.0.0:9294”.
lua: Lua HTTP interface
dbus error: Failed to connect to the D-Bus session daemon: Unable to autolaunch a dbus-daemon without a DISPLAY for X11 core error: no suitable interface module core error: interface "dbus,none" initialization failed dummy: using the dummy interface module... core: stopping playback http warning: ICY metaint=8192 http: Raw-audio server found, m4a demuxer selected packetizer_mpeg4audio: AAC channels: 1 samplerate: 22050 faad warning: decoded zero sample alsa error: cannot open ALSA device "default": Device or resource busy core error: Audio output failed core error: The audio device "default" could not be used: Device or resource busy. core error: module not functional core error: failed to create audio output pi@raspberrypi:~


#8

That’s weird. The key takeaway is this:

cannot open ALSA device "default": Device or resource busy

It looks like VLC is trying to connect to ALSA instead of Pulse. But since Pulse is hogging the ALSA audio output this will never work. Oh good grief this stuff is complicated and makes my head hurt :(

Frustratingly, “default” should be Pulse.

What happens if you:

sudo nano /usr/bin/vlcd

And right under /usr/bin/vlc \ add the line: --aout pulse \

Then sudo systemctl restart vlcd


#9

Oh and also what do you see if you run:

vlc --version

Although right now my working config is on my desk at work unplugged so I have no basis for comparison :(


#10

Just flashed a backup image I made of an older install a while back and its working just fine.
It shows created on October 16 2017.

So something has gone wrong with the current one line installer?

Will try the above in a bit, have to shut down and swap cards.


#11

Probably Pulse Audio in general, but it’s a necessary evil at the moment, since Stretch has a habit of putting the DAC on pHAT BEAT into a bad state. An issue previously masked in Jessie.


#12

I’m running Jessie, the pHat Beat page says not compatible with Stretch.


#13

I’m taking a break from this for now, been at it all day. Neck and shoulders are getting sore, I suffer from spondylosis. I will check into what you posted and get back to you.

Major snow storm happening here at the moment too, need to keep an eye on that. Lights just flickered a couple of times, not good. Need to go make sure the candles and matches are where I think they are.

Talk to you tomorrow some time.


#14

Aye aye! Stay safe. Worst we’ve had here is a lot of wind and persistent drizzle. I think I’d prefer a good snow storm!


#15

Ah crap, just fried one of my Pi Zero’s messing with this. Plugged it into the GPIO one row off. Brand new one, just soldered a 90 degree header on it to make connecting a monitor to my Pirate radio easier. All my fault, getting tired and not paying attention to what I’m doing. Tight courters too in my case. Pirate radio still works so looks like I just fried the Pi zero. No activity lite, no boot. I’m feeding the 5v in via a Proto pHat so it went to the wrong place. First Pi ever that I’ve damaged. I just put the original back in for now. Felling really dumb now, and embarrassed. Oh well, to be honest, its not the first time I’ve let the magic blue smoke out. ;)


Pirate Radio CMD line stuck?
#16

Ouch! If it makes you feel any better I’ve fried both Pi’s and myself plugging things into the wrong places.

Looks like you’re not alone having trouble with pHAT BEAT though, I’m seeing some varied reports across the board of problems with it. I clearly need to bash the rough edges off my PiratePython Radio image and encourage people to use it!


#17

This is my first Pi related fatality that I can remember. I’ve gotten lucky a few times where I messed it up but no harm was done. At least it was a Zero and not a 3B. I’m usually pretty careful and have one last real good look before applying the power. Didn’t see my mistake this time.

Anyway, my radio is running. Should have just used my image instead of redoing it. Would have saved a lot of time. Missed that I had it with all the clutter in my Pi projects folder. That will be fixed to day with some sub folders. One for each of my Pi builds. I had started doing that and got lazy.

A downloadable image, or something you don’t have to do online would be nice. Can the gethub stuff be saved locally and installed from say a thumb drive? I’m a GitHub noob to be honest.


#18

@gadgetoid Still want that info you posted above? I didn’t forget, just a busy day with cleaning up after the storm.


#19

@alphanumeric as long as you’re up and running then no, but thanks for remembering!

I need to publicise the Pirate Python Radio image more, it takes most of the mystery and hassle out of the setup.

Some of the GitHub stuff can be installed offline, but there are still installers that rely on Python packages or Raspbian packes which- in turn- rely on some other dependencies which all need to be grabbed and saved offline for a successful install. It’s possible, but tricky!


#20

Ok, yeah I’m up and running. Is there a link to an image, that I missed? Flashing an image with etcher etc is IMHO the way to go. Might not be faster, but definitely easier.


Pirate Radio CMD line stuck?