Problem with pHAT BEAT

Hi there,

i recently got a used pirate radio kit (even stereo, yay!) with a phat beat. But i can’t get any sound out of it. I tried it with two different RasPi Zeros, Raspbian buster and strech lite, even got a second phat beat unit from someone. Whatever I did: Neither sound nor the LEDs worked. One time i heard some faint cracking but no music.

I know the phat beat isn’t continued. But the tutorials are still online so i thought the software should still work.

Soldering on both phat beat units looks OK. Previous owners claimed that the HATs worked for them.

I tried the internet radio tutorial. RasPi Zero boots up fine. Wifi is connected. I ran “sudo apt get update” and “full-upgrade”. I can even open the web interface of the vlcd web radio and it says it’s playing. But whatever i do, whitchever button i press (both physically and in the web interface): No sound, no LED.

Can someone suggest what i can try to get the phat beats to work?

I’d like to build a multi-room speaker (squeeze / lms). But first i have to get any sound out of that thing…

Greetings

What version of Pi OS did you use? Might want to try Jessie?
Index of /raspbian/images (raspberrypi.org)
The switch to Pulse Audio in Buster has likely broken the installer for the pHat Beat.
Mine is working, pretty sure I used Jessie.

I tried Buster and Stretch. According to github, the pirate radio installer was updated in 2020 in order to work with Buster.

Maybe i should try and reheat the solder points to issue out broken connections? The pre-owner of the radio kit said it was last used a long time ago and he didn’t test it lately.

Can’t even tell if it’s a hard- or software issue because i tried ruling out both as good as i could. I’m not used to github and the tutorials on pimoroni.com just assume that everything works and don’t really go into trouble-shooting.