Pirate Radio - Problems


#1

Hi, just spent all day building and trying to get audio and vu meter to work on the pirate radio, I followed the tutorial on this site.
Initially I had no sound whilst streaming from iphone…shairport-sync[424]: Can’t set the D/A converter to 44100…fixed it by changing the rate in the /etc/asound.conf from 48000 to 44100
But I still am unable to get the pi vu meter to work whilst streaming. I have run the test.py and they all light but when the music is playing I get nothing.
Help please ?


#2

try adding the shairport-sync user to the gpio group, like so:

sudo adduser shairport-sync gpio

… it should work.


#3

Excellent delivery service and now excellent back up service, thank you it worked first time.

Just for any noobs, like me, reading this, remember to reboot after entering

sudo adduser shairport-sync gpio

for the changes to take effect.


#4

damnit

/me goes and cries in the corner


#5

yes (thought technically restarting the service probably works too).

Our installer is supposed to prompt you to restart though (as well as set the correct rate) so that’s not something we expect people to have to suss out or do manually…let’s just say the last week has been pretty eventful :D


#6

I am sure I speak for most of the people on here by saying we appreciate your “back up service” …most companies sell and run…I have no doubt you will update the installer.