Pirate Radio


#1

Hi,
I bought a Pirate Radio kit. I did the assembly by following the guide “Assembling Pirate Radio”.
For Internet radio, I have used the guide “Internet Radio on your Pirate Radio”.
After a few minutes of operation vlc crashes. If I restart VLCD service it works again but
the VU meter and buttons do not.
What should I do to solve this problem?
For the OS, I am under 2017-09-07-raspbian-stretch-lite.
Thanks for the help.


#2

Try replacing your /etc/asound.conf with this:
https://raw.githubusercontent.com/pimoroni/pivumeter/df8d9f5dc9edd4c91b3009771cd95bbf039ec58f/dependencies/etc/asound.conf

I hope to replace the version that’s installed with this one, once I gain confidence that the fix works.

There appears a problem with the dmix plugin in Stretch that corrupts the audio buffer and causes Pi VU Meter to crash. This conf file removes dmix.

You may also want to follow the steps here for pop reduction: https://gist.github.com/Gadgetoid/3301cec3e47495e75b31d3120d8f17d9


#3

Hi,
Thank you for the answer.
I’ll try it on.


#4

My Pirate radio has some problems aswell.

After trying the pop reduction gist, I get a really gabled bit of audio before it starts after a few seconds.

There is no pop but the garbled sound is even worse! I don’t think I made a mistake following the tutorial but it could be useful to have full complete correct versions of the files to copy and paste in.


#5

Hi,
The modification of the asound.conf file solved the problem of vlc crashing.
For the others modifications, I have not heard much improvement.
There are commutations noises. Can they’s resolved?
Thanks for the help.


#6

Hi,
After some tests, for me the most satisfying solution is the modification of asound.conf.
On the other hand, it substitutes a hard/soft problem under the following conditions:

  • when the play/stop button (>||) is pressed the speaker is traversed by a current of approximately 1 A (4 V DC at the terminals of the speaker).
    The speaker temperature is more than 70 ° C after 4 hours.
    (The kit consumes more energy in pause than in operation) ;)
    I have temporarily solved the problem by inserting a blocking capacitor in series with the speaker. (conventional in the amplifiers)
    Regards

Pirate-Radio, pivumeter, Stretch
#7

This is strange- almost like VLC is holding the audio device open with the last sample value- we noticed something like this before with YouTube but could never replicate it. I’ll need to set up a test and look into it again.


#8

Hi,
There is no problem, you can replicate the state with the test of the hold button.


#9

See my answer here: Pirate-Radio, pivumeter, Stretch


#10

Thank’s for the answer