Plasma 2040 glitching on update

Hi!

I have a plasma2040 linked up to a 144 LED per meter strip, both bought from pimoroni.

I’m using a 6amp external power supply, with a 1k capacitor, and I’ve dutifully made sure that the ground is shared between the controller and the power supply.

When I do the sample script with the rainbow effect, the LEDs glitch like crazy. By setting the update frequency to time.sleep(5), I’m able to reduce the glitching to one flash every 5 seconds.

Any idea why this might be? I’m lost.

Thanks

I don’t own one, but had a look at the rainbow example.
Correct LED type set?

I checked this out and the cause was bad soldering on my part 😔 the project is really coming together, although it sometimes feels like one step forward, one step back.

Soldering is an acquired skill. It takes some practice to get good at it. Easy to mess up even for some of us that have been doing it for a while.
I’ve had a few projects that seemed like one step forward two steps back. That usually starts when I get to the coding part of things.
It’s very rewarding, and satisfying, when you get to the end with a working bit of tech that you built.

Hi!

Still struggling with this. Right now I have a controller which glitches with my LED strips unless I touch the Data In cable with my bare hand. Any advice? I can’t find anything about this, anywhere… (and this is not one of the strips I have soldered!

Thanks for your help so far with this and my other questions.

Plasma 2040 strip flicker - Support - Pimoroni Buccaneers

Hi!

I’m not using the strips described in that post, I don’t have a clock and data line (only data) so it’s not really relevant. In fact, at the end of that thread, there’s a comment from a guy who IS having the same problem as me, saying that the thread was not helpful.

In any case, I tried playing with the argument at the end of the “plasma.WS2812(NUM_LEDS, 0, 0, plasma2040.DAT, 400000)” and… now Thonny can’t find the device. I have put the plasma2040 into bootloader mode and reinstalled the uf2 file, reset, turned everything on and off again, and it still doesn’t connect to thonny.

Any advice on totally flushing and resetting the plasma2040 to factory settings? And start again from 0?

There is a uf2 file that can do it, under Resetting Flash memory. It’s as close to factory as your going to get.
Raspberry Pi Documentation - Raspberry Pi Pico

Thanks.

Edit: The dramatically named flash_nuke.uf2 worked. Thanks! Now to see what’s happening with these strips…

Yeah, interesting name for that file, lol. As far as i know its safe to use on any RP2040 based micro controller board. I’ve used it in my Pimoroni Tiny 2040 8mb and Pico Lipo 16mb boards.

Interestingly that Plasma2040 has the same problem. I’ve tried it with a LED strip from Pimoroni and one from Amazon, same thing happens both times. I’ve also tried the same LED strips with a different plasma2040, and it works fine then. So my Plasma2040 is definitely at fault. I’m very curious about what happened here and how i could avoid it in the future.

Recap: unless I touch the Data cable on my plasma2040 with my hand, my LED strip glitches. My plasma2040 has an IO expander soldered onto it with a load of buttons attached to it (in pull up mode), but the problem occurred a few weeks after I started using the IO expander, so I doubt they are related.

Possibly daft/obvious suggestion - but how do you have your LEDs connected to the Plasma? If it’s via a connector like this it might be worth checking the continuity of the connector and that the wires are making good contact with the screw terminals. Wire poking stopping glitching sounds to me like you might have a duff connection somewhere.

Thanks for your reply. And please: there are no daft/obvious suggestions as you are dealing someone with 3 months experience 🙏

The situation is: the data cable is tightly screwed in to the plasma and protected by hot glue, so it’s not actually possible for me to check that connection, but it would be very very surprising to me if the connection was loose under the hot glue. There is only one other connection between the controller and the cable going into the LED strip and I’ve checked it many, many times (that is the connection I am able to touch with my bare hand).

I don’t get the feeling the connection is loose because:

  1. the glitching is not random- it works perfectly when I give it the touch, and it works incorrectly in the exact same way (LEDs that should be red are green).

  2. If the connection to the plasma was loose I wouldn’t be able to temporarily fix it by touching the other connection.

  3. It’s not about wiggling, it’s about lightly touching a bare wire. I wiggled everything (first thing I tried). Wiggling the cables is probably the technique I know best and use most- I don’t know much, but i know wiggling.

I have run the exact same code on my other plasma2040 with the same LED strip and it works fine by the way so I would guess the code is correct. No GRB or RGBW problems here.

Wiggling rocks :D

Hmm, that’s very odd - especially if it works OK on another Plasma. Can you send some photos/video showing the magic touch point in action?

I’ll make a video demonstrating the problem as clearly as possible later today

Edit: I unplugged everything then plugged it back in and now it works 🤷‍♀️

Thanks to everyone for your help and patience. Mission accomplished