Player X USB Not Mounted on Reboot (Pi Zero)

Looks like it won’t be recognized by a Pi Zero unless it is physically unplugged and plugged back in after boot. I’m trying to build my project in an enclosure. Has anyone found a way around this? I tried to reset usb through the terminal like in this post but doesn’t work, as the post mentions.

I also tried to make an rc circuit with a transistor as switch but that’s not working either.
I really need to get this to work, as I have no access to GPIO since the HyperPixel is part of the system as well.

After some testing, it behaves differently between reboot, shutdown → cut power, and just cutting power.
Rebooting and just cutting power results in RetroPie loading to the game selection screen, as if a valid controller is plugged in and ready to go, and it responding to no input. Shutdown → cut power has RetroPie boot to the button mapping screen as if nothing is plugged in.

All of these are fixed by unplugging the Player X and plugging it back in. There must be some way to get it to reinitialize!

Does it mount from a cold startup? Full shutdown, with a power cycle?

It does not mount on a cold startup, no :(

Allow me to elaborate:
RetroPie actually boots into the game selection screen, which means it totally is recognizing that a previously-mapped controller is currently connected. It just accepts no inputs from it whatsoever.

I will edit my original post now

Ok, just probing for info, based on thread title. I did read your original post though. ;)
JFYI, I don’t have a Player X and don’t currently use Retro Pi.
I wonder if its something unique to a Pi Zero? Do you have a different model Pi to try / test with? My Pi Zero’s will reboot if i connect anything to the Data port after boot up. If I plug my Hub etc in first, then boot up, things are fine.