Server timeout

I’m trying to download to my zero w but every time I get the error message “failed to connect to get.pimorini .port 443 server timed out”.I’ve updated everything first and rebooted.what am I doing wrong.
my setup is: pi zero w,phat stack,phatbeat,pianohat,drumhat.

What are you running from terminal when you get the timeout?
Do you have a reliable WIFI connection to your router?
Do you have a reliable Internet connection from your router?

Thanks alphanumeric.I’m sure I have good internet connections (other devices work normally) >having said that,updating the software and using the chromium browser seems slow.
I’m not sure what ‘running from terminal’ means but I typed in this:
curl (also/drumhat and /phatbeat )
i’m trying to make the “itty bitty beat box”.

its on the taskbar

i have same setup,i followed this to get mine working

That’s what I followed,but no luck so far.

As a bit of a novice, I can only tell what I would do ,reimage my Sd Card and start over

Running from terminal basically means running from the command line. If your running PiOS lite you are there by default. If your running the “with Desktop” version it will boot to the desktop GUI. To open the terminal you click the black icon in the tray.

There very well could be an issue with the server. If so I would expect it to be fixed pretty quickly. Take a break and have another go at it tomorrow. If your still having issues then post back here.

I understand now.I’m using Desktop.Was I right to type “curl” before https…etc.?

Yes curl | bash


If your using a speaker pHat its
curl | bash
Then run, not sure what folder its in.

curl | bash
cd /home/pi/Pimoroni/drumhat/examples
To test it

curl | bash
cd /home/pi/Pimoroni/pianohat/examples
To test it
If you edit and change
patch_index = 0
patch_index = 1
It will then default to piano sounds on all the keys.

I’ll try that-if I ever get to download the code!At the moment it’s looking like an expensive mistake.
Thanks anyway.

did you try taking it all off the phastack and just do one at a time on the Pizero

They might be doing server maintenance? They will often try to minimize down time and inconvenience to users by doing it when it should least used, like a Sunday. ;)
Just take a break and have another go tomorrow some time.
I have my 4B desktop booted up, I’ll have a go myself in bit when I get a chance.
I’ll post back how it goes for me.

The drumhat installer worked without issue for me.
curl | bash
I don’t have a drum hat installed to test, but the installer ran without any errors.

UPDATE: The pianohat and speakerphat installers also worked without issue for me.
You must have an internet connection issue between you and github?
Or your firewall / router is blocking it?

Yes I’m beginning to suspect it’s an internet issue. I’ve used github with Atmega projects before,usually without problems (on my pc).I’ll look into it tomorrow.Thanks guys!