Curl https://get.pimoroni.com/inky | bash

Hi,
I am trying to download the Inky Python library using the following at the command prompt;

curl https://get.pimoroni.com/inky | bash

However, I receive the following error message;
0curl: (7) Failed to connect to get.pimoroni.com port 443: Connection timed out.

I have tried this a number of times and on different Raspberry Pi devices, but still get the same result.

Is anyone able to help me with this issue please?

Many thanks in advance.

Kind regards,
Trev

Some of our URLs seem to be having some DNS problems at the moment, we’re working on it 😬

You should be able to install Inky from Github in the meantime:

git clone https://github.com/pimoroni/inky
cd inky
sudo ./install.sh

You might also need to enable I2C and SPI in sudo raspi-config.

Many thanks for such a speedy response.

1 Like

I encounter the same problem for the installation script of the explorer hat pro:

https://get.pimoroni.com/explorerhat

I failed at installing this via GitHub manually. Thanks in advance for working on this!

get.pimoroni.com should be back up and running now :)