Speaker pHAT is getting very warm/hot when playing audio/video


#1

Hi there,

I was trying to get this mixtape to work for my wife.
I’ve just soldered my Speaker pHAT the other day and today I tried it to play some audio. But I noticed when I switched the Raspberry Pi Zero with Speaker pHAT off, the speaker or at least the magnet is burning hot. And also the pHAT smells a bit like burning plastic.
So now I’m afraid I might have burned the speaker. Or should a heat sink on the pi suffice to fix this?

I’m no soldering ninja, so maybe I’ve also shorted the circuit somewhere.

Hope someone can help me out.

Willem


#2

Are you running Raspbian Stretch?

A change in Stretch - the removal of Pulse Audio - revealed a problem with ALSA where it does not properly close the audio device. Running the i2s clock, but not the LRClock. The DAC chip we use doesn’t like this at all, and leaves the L/R connections of the speaker at +5v and GND respectively. This puts 5v through the speaker (effectively a low-value resistor) and turns it into a tiny heating element.

Sorry about this! I’ve been working over the past few weeks to diagnose the underlying problem and make a case for an upstream fix.

In the interim, you should follow the steps here to reinstate Pulse Audio: https://gist.github.com/Gadgetoid/3301cec3e47495e75b31d3120d8f17d9

Chances are your speaker will still be okay. Let us know if otherwise!


#3

Thanks. I’ll try this tonight.


#4

Thanks for this advice, I experienced the same problem.


#5

I’ve pushed some updates to the Speaker pHAT and pHAT BEAT one-line-installers to automagically do the Pulse setup. It’s something I was hoping to avoid, but it’s a safe bet for the time being.

I am hoping we find an upstream fix that makes the i2s behave itself. I’ve certainly managed to make it work with a very small kernel tweak, but that’s not something I can easily distribute.


#6

Just a reply to say it worked. Thanks! :)


#7

Excellent! Thank you for letting me know.


#8

I have updated using the new one line installer for phat beat, the solution seems to correct the heat problem, however I lost the led lights on the phat beat. I also used the one line installer for vlc radio which appeared to be the same correction, (perhaps unnecessary?), but still no led functionality. Do I need to install a fix for the led lights on the phat beat? BTW - it boots up with the lights flashing upon boot up, but nothing illuminates once on. The “old” version always had the bottom row illuminated after boot, and initial flash. Thanks for the fix on the heat issue!


#9

Sorry my installer had a bit of a bug with an earlier version where it would install Pi VU Meter after installing PulseAudio but the PulseAudio installer would try to detect Pi VU Meter and add support if it found it- slightly impossible if it’s installed after!

You can either re-run the PulseAudio installer, or tweak your /etc/pulse/default.pa to add these lines:

### Try to load pivumeter if it exists
.nofail
load-module module-alsa-sink device=pivumeter
.fail

Before the line:

### Automatically load driver modules depending on the hardware available