Speakerphat software won't install


#1

Hi,

I’m trying to install the speakerphat setup software using the one line command:
curl -sS https://get.pimoroni.com/speakerphat | bash

I just get two error messages:

curl: (3) malformed
curl: (6) could not resolve host: bash

For what it’s worth, my keyboard’s | symbol looks like a ~ when viewed in terminal…

Any help would be appreciated


#2

actually the first error message is

curl: (3) malformed


#3

Your using the wrong keyboard layout.

Full Raspbian or Lite? In the full Raspbian you just go to Preferences > Raspberry Pi Configuration via the menu and change your keyboard layout. Localization tab . keyboard layout. The default is English UK, I set mine to English US > English US with Eruo on the 5. That matches everything up for me.

If it’s Raspbian lite you need to run sudo raspi-config to do it. Menu’s are bit different but its the same idea. Finding the right keyboard layout is tricky though, its the old interface.

I had the same issue from terminal in Raspbian lite, I could not get the | symbol on my keyboard even after trying a few different layouts. I eventually gave up and went to full Raspbian.


#4

If the bar character continues to elude you, you can also try:

sudo apt install pimoroni
pimoroni-dashboard speakerphat

#5

I’ll have to remember that. Not being able to find the pipe symbol on my keyboard caught me out once. Jessie lite, terminal interface. I ran raspi-config and tried several different keyboard layouts with no luck.
In full Jessie, selecting English US as above and its where it should be, above the . Always nice to have options.


#6

Thank you! I did the keyboard switch and the software loaded perfectly!!


#7

Good stuff. Have fun. =)