Successful install but unresponsive Unicorn Hat


#1

Hi, I just received my Unicorn Hat for my Raspberry Pi 3 Model B. I installed the software following the instructions from https://learn.pimoroni.com/tutorial/unicorn-hat/getting-started-with-unicorn-hat

However I’m not getting any response from the Hat. Is there a particular way I should be connecting the Hat to the pins? I’ve tried a couple different approaches as shown in the photos below and yes the device was plugged in during testing. I ran ‘cd ~/Pimoroni/unicornhat/examples/’ and ‘sudo python ./simple.py’ in Terminal with no success on the Hat.

In this example, I tried resting the Hat by the pins alone, then tried resting it by the pins and some plastic but neither approach seemed to have any success in getting the LEDs to light up.

Any help would be much appreciated! Thanks!


#2

Hi @redmond, you need to press the HAT down on the pins firmly so that the metal of the pins is fully inserted into the HAT and no longer visible.

Hope that helps.


#3

Hi @major_tomm, I tried pressing down on the HAT but didn’t want to risk damaging the pins. Will try again more firmly when I get home. Thanks!


#4

Sometimes HATs can be a bit tough, just make sure the pins are all lined up before you push down. (From the photos it looks like pin 39 on your Pi might be slightly bent?)


#5

Stand offs help. They pretty much guarantee your hat is pressed in to the correct height without damaging things.
Two sets of these, https://shop.pimoroni.com/products/brass-m2-5-standoffs-for-pi-hats-black-plated-pack-of-2
Or, https://shop.pimoroni.com/products/premium-pi-standoff-selection

They will also prevent things like your heat sink shorting out the underside of the hat.


#6

Any light at all, like on boot up? Also, what is the current rating of your power supply?


#7

@alphanumeric thanks will check out the stand offs. still new to this whole thing. and no light comes on whatsoever. I’m not sure what the rating is but I’m using the official raspberry pi 3 power supply. could just be that I’m not pressing down firmly enough on the HAT as @major_tomm suggested


#8

If its a current issue, as in not enough, you should see a yellow lightning bolt flash up on your monitor. That is an under volt indicator. It pops up when your power supply voltage drops due to excessive current draw. The official raspberry Pi power supply should be enough for this though, so that’s not likely your issue. If you read the fine print on the power supply it will give the voltage and current rating.

It should fit firmly and be a bit hard to remove.


#9

@major_tomm no pins are bent and pressing more firmly managed to do the trick! thanks again!