TouchPhat and PiZero w problem


#1

Tested TouchPhat on Pi 3 and works perfectly.
But on PiZero w i get the following errors-

>>> import touchphat
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/dist-packages/touchphat/__init__.py", line 13, in 

<module>
    dh = cap1xxx.Cap1166(i2c_addr=0x2c)
  File "/usr/lib/python2.7/dist-packages/cap1xxx.py", line 283, in __init__
    self.product_id = self._get_product_id()
  File "/usr/lib/python2.7/dist-packages/cap1xxx.py", line 469, in _get_product_id
    return self._read_byte(R_PRODUCT_ID)
  File "/usr/lib/python2.7/dist-packages/cap1xxx.py", line 494, in _read_byte
    return self.i2c.read_byte_data(self.i2c_addr, register)
IOError: [Errno 121] Remote I/O error

I have just updated Raspbien today and it still does not work.
Can anyone glean the problem here?


#2

Looks like you might not have I2C enabled?

Try running curl https://get.pimoroni.com/i2c | bash in the terminal.


#3

Cheers, it was the first thing I did but will do it again in case there were any errors


#4

I ran that again but same error comes up. Could it be a gpio pin error?


#5

Resoldered the Pi Zero pins and now the TouchPhat works