Ubercorn always displaying red line unless power disconnected

Hi, there. Back with yet another Ubercorn/Unicorn HAT (HD) issue.

I have a RPi4 with an Ubercorn on it. Other than testing to make sure that it works, I haven’t used it at all, as I’m not yet done with the data that I need to gather before I can start making use of it.

At some time in the past 24 hours, it has begun to display a dim red line across the array (all but one of the LEDs is lit). It’ll still display any script that I run, but as soon as I stop it, the red line stays on, even after shutdown. The only way to make it go away is to physically disconnect power from the RPi4.

This behaviour is sort of similar to my first Unicorn HAT, which after very little use began failing horribly, with whatever lights displaying properly for a few moments before sputtering, fading to dim red, and sitting like that through restarts or shutdowns, only disappearing if I physically disconnect power. I never got any response on what might be causing it or if it might be a faulty HAT, but it’s still not working either, so if anyone reading this happens to know anything about the Unicorn HAT, I’d love to finally know what’s up with that one, and if the problem is related to this one.

I haven’t touched the unit in a week, so there’s literally nothing that I did that I could undo. As soon as I provide power back to the RPi4, the red strip comes back, so it really does seem faulty for me. Unfortunately, for its planned purpose, I can’t use it with the red line present.

Any thoughts?

Edit: Had the power disconnected overnight. Upon plugging it back in this morning, the red strip didn’t display!.. for about two seconds, then flickered for a moment before coming back exactly as before. Disconnected and reattached the HAT with no change, and tried it on another RPi4 again with no change.