Unicorn Hat HD mysterious red line

Hi! Recently I purchased a Raspberry Pi 3A+ and a Unicorn Hat HD. For the first day or so it worked perfectly however, recently a mysterious faint red line has appeared (see image). This line of LED’s will not turn off unless I turn off the power at the wall. I have tried turning off all LED’s through python, I have tried reseating the hat and I have even tried putting the hat on my older Raspberry Pi 2, where the issue still persists.

Is my board faulty? If so, what could have caused this? I didn’t touch the board at all before this began happening.

Any help would be appreciated :)

That line of LED’s lights up as soon as you apply power?
Or only after running code on the Unicorn Hat?

Make sure the underside of the Hat isn’t touching anything metal on the Pi like a heatsink.

Yeah, as soon as they slide into the GPIO pins the LEDs come on. The hat isn’t touching anything on the Pi either.

That’s your issue. You should never plug in or unplug anything on the GPIO header while the Pi is powered up. You need to remove power before doing that. It’s likley damaged the HAT and or Pi.

Ah I see, well that was definitely a mistake on my behalf as I am fairly new to using Hats on the Raspberry Pi. However, the light problem happened before I attempted anything like this so I can say with certainty that doing that did not cause this issue.

you didn’t have to attemp anything .believe me I have been there before

It’s a hardware issue, how long ago did you buy it?

I got the Pi and the Hat only just last Friday

The following link will let you e-mail Tech support to see what they say. I’d put a link to this thread in that e-mail.
Contact Us for Raspberry Pi Technical Support – Pimoroni

I’ve dropped support an email with all the information - hopefully it gets sorted! I also found out someone else has had exactly identical issue as me with an Ubercorn (Ubercorn always displaying red line unless power disconnected), so at least I’m not alone 😂

I have two Unicorn Hat HD’s here. One has been running 24/7 for many months without issue. The other one see’s regular use and has also been fine.
I did get one that had a dead Red LED and it was replaced without any hassle.


I had exactly the same issue with an UnicornHatHD. Red row of LED’s anytime there was power connected to the board. I set up a return, it was exchanged by the good folk at Pimoroni, quickly.

I noticed in my fault finding process that the issue seemed to occur after using the “ArcadeRetroClock” package. While it should be noted that this package for the UnicornHatHD may not be the cause of the red line issue.

I ran it once on the replacement hat, and the red line faintly returned. Left the hat unpowered for 24 hours, removed that package, not used it since. The faint red line vanished and the UnicornHatHD has be working like a charm ever since.

Posted with an apology for (I believe it’s “DataGod”) the developer of the “ArcadeRetroClock” they have has clearly put a lot of time and effort into it. It’s a nice clock program for the hat. I particularly liked the space invaders one.

But, for me at least it seemed to be related to the red line issue. Feel a bit bad making that connection, but it was the only thing I could causate the red line issue with. One other thing I noticed is that “Leddy” allows the setting of a fixed FPS. I may have missed it, but didn’t see the same option with the ArcadeRetroClock.

TL:DR - Pimoroni exchanged mine with out any fuss.

I haven’t run anything on mine other than the Pimoroni examples and my own code.
I did up my own test.py that turns all the LED’s Red for 5 seconds, then Green then Blue. It was a quick easy way to find any dead LED’s.
Mine are displaying scrolling text messages that change color based on conditions. Usually at 50% brightness. One will go full bright if the background light is high.

One thing with smart LED’s is, they retain the last state they were in when you stop sending any signals / data to them. They stay lite until you remove power. I have a clear routine in my python file to turn them all off just before my shutdown command is issued.

Yeah I also have only ran the example code and a bit of my own basic stuff so far. I did try re-flashing my SD but as expected, that did not fix the problem. However, I have contacted support and arranged a replacement to be sent to me. Thank you for all the support and info everyone!

1 Like

In the past few days, I’ve now got the red line back again. Gah.
Repeating same steps, isolate from power and host pi zero for 24 hours. Will report back.

That sucks. I had a PICO RGB Keyboard base that had one LED that lit up faintly Red. Just enough that I could see it, and just enough to mess up what color it was displaying.
I got a replacement and that one was fine. In my case its likely that one LED is faulty. I’m not sure what’s going on with your Unicorn Hat? My best guess is its one of the 3 LED driver chips?
On the plus side, my one Unicorn HD that’s been running 24/7, and gets a workout, has been fault free (knock on wood). My code crashes every once in a while, but the Hat is fine on a restart lol. I don’t know if it matters, but that one runs at 50% brightness. It’s just enough to read it in a lit up room, and not overly bright in dark conditions.
My second one, that’s running almost identical code, will occasionally run at full brightness if the background lighting is a high level, (very bright sunlight). It’s run like that for hours with no issues, other than reducing my run on battery time.

After an over 24 hr isolation. Red line is still present. Though may be a little dimmer. At times flickers.

I’ve sent unicornhathd.clear() and unicornhathd.off() scripts to it, many times. This hat is a replacement from the original I purchased in mid June. Grateful for an exchange in July. Now it’s done the same thing again. I’ve had a months use of each so far.

As DotLouis points out there seem to have been several instances of this happening. Wondering if there is a bad batch with a dodgy bug on the rear. Could be quite hard to isolate. AFAIK, the Ubercron is much the same thing but scaled up.

It’s never been used over 50% brightness. To run what used to be “gameframe” before it went open-source. Now “Leddy” GitHub - muldjord/leddy: Displays pixelly goodness on a Unicorn HAT HD or Ubercorn for the Raspber

It’s frustrating, now potentially looking at another return, for the same thing to happen in a months time.

It’s hardly noticeable when running, so I may just resign to it.