Unicorn Hat has failing pixels


#1

Hi, I first tried my Unicorn Hat on a new Pi Zero W but got the ws2811_init failed with code -1
Exiting cleanly error that other people have reported.

I have now put it on a Pi 3 and it works almost fine, apart from a few pixels. On one LED the red has never worked. A couple of others have failing red or blue sometimes.

I have done the apt-get upgrade, update etc and turned sound off in config.txt, but no joy. It’s powered by the ‘official’ adapter.

Is it just a bad unit, or could there be another explanation?

Many thanks,
Steve


#2

could well be, yes, if you get failures consistently on the same pixels then there’s not much in software that could explain that.

Contact support@pimoroni.com and they’ll sort you out a replacement.


#3

Many thanks for that - I’ve contacted support.
Best wishes,
Steve


#4

This was fixed a few days ago, there are instructions in the bannered topic but if you’ve dismissed it already, you can grab the latest library with:

sudo pip install rpi_ws281x --upgrade

#5

Thanks gadgetoid - I’ll give it a try.

Best wishes,
Steve


#6

Hi Phil,

I’ve tried that on my Pi Zero W and it works fine, thank you. I still
have dead pixels on the Unicorn Hat, but support are sending me a new one!

Thanks and best wishes,
Steve