Unicorn Hat HD SPI Timeout Problem


#1

Hi,

I’m driving a Unicorn Hat HD with a Pi Zero (Raspian Jessie) and I get frequent SPI connection errors after approximately 20 seconds (time varies) whenever I run the example programs from the unicorn hat hd python library.


The only exception is the stars.py, which I assume is because of the low data rate needed for this simple program. I use a 2A 5V external power supply connected to the pi, so power should not be the problem.
Do you have any idea how I can test if the onboard chip on the Hat is working correctly regarding SPI?
Best Regards,

Timo


#2

This is odd. Mostly because there’s no real connection to speak of- Unicorn HAT HD is write-only, so the example will continue to run quite happily even without the HAT on top of the Pi (I use this as a magic trick when demoing Pi stuff at events.)

Try running the same examples without the Unicorn HAT HD on your Pi and see what happens.


#3

Thanks for your prompt reply. I found the problem after I got the same error without the hat. I had my pi set up to automatically run a unicorn phat program on boot and embarrassingly forgot about it. This interfered with the spi bus, although I know how.


#4

This happens! (even to me)