Unicorn Hat not lighting completely


#1

I just received my unicorn hat and got it installed and setup by following the instructions below.

Not all my LEDs are lighting up. It seems only the first 3 rows are lighting. This is a picture of the Unicorn Hat when running the bluesky_greengrass.py script. Any help is greatly appreciated!


#2

I also just tried installing a fresh version of Raspbian with the same results. It appears as though my unicorn hat is defective. I guess I will contact Amazon tomorrow unless I receive any suggestions. Thank you in advance for any help.


#3

Have you disabled the onboard audio?

You can try running this command:

curl -sS https://get.pimoroni.com/audio | bash


#4

I’d be surprised if it’s a fault with the Unicorn HAT itself- it looks like it may be the onboard audio causing a problem as @pi2003 suggests. You can force it out via HDMI using the script mentioned.

If it were the Unicorn HAT that was faulty, it wouldn’t be likely that you’d see odd LEDs lit up in the way you are- the LED chain would stop abruptly at the defective pixel since they’re all daisy-chained together in one continuous strip.


#5

Actually I made my own script that lights up all the LEDs. It does stop on one certain LED and will not light fast that LED.

I have tried disabling the camera, and I2C as my seller suggested. I have also tried forcing audio out via HDMI instead of the 3.5mm audio jack.


#6

There is a difference between routing audio to HDMI and forcing audio to HDMI, if you don’t tell us what steps you have taken, it’s impossible to tell whether the highly likely root cause for your problem can be discarded.

So, please, so we may help you, please be specific about what install procedure you have followed (the link you posted contains 3 different protocol of installation, from recommended to fully manual).


#7

Here are the full steps I have done:

I ran “\curl -sS https://get.pimoroni.com/unicornhat | bash”, During this process it did ask if it would like me to run the script that would force audio through HDMI, and I selected yes.

then I did the instructions for “Install for Python 3” which are:

sudo apt-get install python3-pip python3-dev
sudo pip3 install unicornhat

I then followed the instructions for “Install from Github clone”.

This is when i tried to run examples and ran into problems. Looking online I saw that people had better results running it headless, so I unhooked my HDMI and used VNC to login and run the example scripts, still had the same results. I then installed a fresh version of Raspbian from their website, and followed the same instructions above, with the same results.

I don’t believe I have run the “curl -sS https://get.pimoroni.com/audio | bash” command. I will try this when I get home from work. Any other suggestions would be great. Thank you all for your help!


#8

This fixed it! Thank you a ton for your help!