Warning, could not find Analog or Touch... Please check your i2c settings!


#1

Hello,

After update and upgrade my RPI3 I got this message… My son would like to start with his Explorer Hat but I cant get the i2c to work. Can anybody help me? i2cdetect -y 1 (at the bottom) did not retrun an adres…

Thanks!

Rikkert

@raspberrypi:~ $ sudo curl -sS https://get.pimoroni.com/envirophat | bash

This script will install everything needed to use
Enviro pHAT

Always be careful when running scripts and commands copied
from the internet. Ensure they are from a trusted source.

If you want to see what this script does before running it,
you should run: ‘curl https://get.pimoroni.com/envirophat

Note: Enviro pHAT requires I2C communication

Do you wish to continue? [y/N] y

Checking environment…
Updating apt indexes…

Checking hardware requirements…

Checking for packages required for GPIO control…
…RPi.GPIO installed and up-to-date

I2C already enabled

Checking packages required by I2C interface…
…smbus installed and up-to-date

Enviro pHAT comes with examples and documentation that you may wish to install.
Performing a full install will ensure those resources are installed,
along with all required dependencies. It may however take a while!

Do you wish to perform a full install? [y/N] …y

Checking for dependencies…

Installing python-envirophat…
install ok installed
Installing python3-envirophat…
install ok installed

Checking for additional software…

Downloading examples and documentation…
Resources for your Enviro pHAT were copied to
/home/pi/Pimoroni/envirophat

All done. Enjoy your Enviro pHAT!

pi@raspberrypi:~ python -c 'import time, explorerhat; explorerhat.light.on(); time.sleep(1); explorerhat.light.off()' Warning, could not find Analog or Touch... Please check your i2c settings! pi@raspberrypi:~ ^C
pi@raspberrypi:~ $ i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – -- – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: – -- – -- – -- – -- – -- – -- – -- – --
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – --


#2

I can’t recall what the failure mode for i2cdetect is when i2c isn’t fully enabled, but it might be worth checking Raspberry Pi Configuration (or sudo raspi-config from the command line) and double-checking i2c is enabled, and/or turning it off then on again, as a first point of call.


#3

Try following the tutorial here to manually turn on I2C again.


#4

Could be fried? Mine was showing that. I presumed it was a Rasbian issue as I had everything working and then my SD card corrupted. I rebuilt with stretch and I couldn’t get the explorer phat working. So rebuilt again with Jessie and still didn’t work.

I tried another explorer phat I had sitting around and that worked fine. So it seems my original phat just failed. :(