Adafruit Capacitive Touch Hat


#1

Hi all,

I need your help!
I connected Adafruit Capacitive Touch Hat and I can see the LED light is on the Hat so I believe it’s well soldered and connected properly with Pi.

But what’s next? I’m a beginner and no idea how to start.
Obviously not hear any sound yet.
I want make the sound drum like Adafruit demo video.

Many thanks.


#2

I haven’t checked Adafruit’s site, but I’d be surprised they don’t have a tutorial covering that.

If you can’t find one, then you could take a look at the Drum HAT examples we have in our repo: https://github.com/pimoroni/drum-hat/tree/master/examples

it’s essentially relying on pygame to drive the sounds when a ‘trigger’ is detected. It’s not the same chip at the heart of Drum HAT though, so I’m afraid you can’t just use those examples without checkout the Adafruit lib and how to address the triggers.


#3

there you go, pinout.xyz to the rescue!

seems very similar.

and here’s the tutorial linked from the product page at Adafruit:


#4

Hi RogueM,

Thanks for your support.
After some hours search and try, I managed to install the Arduino IDE.
I uploaded MPR121 test but then tool - serial port is grey colour inactive.
So I can’t start.

Then I tried another link that work straight on terminal.
Again worked all well until below capture.
The left is the link how it should work on the dark grey window.
The right is my terminal which is something different after Adafruit MPR121 Capacitive TOuch Sensor Test.

Again thanks for your help.


#5

Have you enabled I2C?

try:

curl -sS get.pimoroni.com/i2c | sudo bash

then try again. If that fails again, run:

curl -sS get.pimoroni.com/diagnostic | bash

and post the output here


#6

Hi RogueM,

Thanks again for your support.
Enabling i2c made me some progress.
Below is where I am stuck.
Thanks.


#7

I’m afraid I can’t really help - I suspect that script requires some level of user customisation. I would recommend trying the Adafruit forums, who wrote those examples and the tutorial.


#8

on second reading, it could just be that the uinput module is not installed. I don’t have access to a pi right now so I do not know if you could install it straight from the repo, or you have to use pypi, but try:

sudo pip install uinput

that might work (and help).