Adafruit PiOLED gethub link issue?


#1

Hey guys, first post… I have a fair amount of experience using ssh and “copy n paste” code. But Ive caught a snag and wondering if its a bad link or if I’m using the link incorrectly… I should mention I’m using a Pi Zero running OS Raspbian Stretch Lite.

Im following the basic Learn Tutorial on adafruit. and everything goes well untill I get to
" https://github.com/adafruit/Adafruit_Python_SSD1306.git "

And I get the response of
-bash: https://github.com/adafruit/Adafruit_Python_SSD1306.git: No such file or directory

Can anyone tell me whats going wrong here? I’ve done this before about 3 weeks ago. And cant seem to figure it out again. Thanks in advance… -Tim


#2

What are you typing into the terminal when attempting to clone the GitHub repository?

Looking at the repository itself, and the readme: https://github.com/adafruit/Adafruit_Python_SSD1306

It seems you can probably just:

sudo pip install Adafruit-SSD1306

#3

Thanks for the reply… I tried that but then the rest of the commands input return with a “command not found” “no such file or directory” type stuff… This is the string of commands

sudo apt-get install git
git clone
https://github.com/adafruit/Adafruit_Python_SSD1306.git
cd Adafruit_Python_SSD1306
sudo python setup.py install

The link for the turtorial I’m following is


#4

So Ive tried multiple times, On new SD cards. With both versions, Desktop and Lite. Ive tried doing it all on the actual pi, And also with ssh… And I cant get this link to work. Ive finished 3 pi projects since then. And I just cant get this working… I notice the pioled has been out of stock since I got mine… Is there a glitch? How do I get my product to work? About to give up.


#5

I really wish I could get some more support here… This has to be the easiest thing Ive done with a Pi and cant get it to work. I cant see how it could be an error on my end. I would like to know for sure that its not within the tutorial or the link… Can anyone try the tutorial… You dont need to have a PiOled. you just need to get the link working that Im having so much issue with…


#6

It’s quite possible you have a connectivity problem that’s causing git to fail to fetch the repository. Could you snap a photo of any error output you get for the git clone https://github.com/adafruit/Adafruit_Python_SSD1306.git step? This step runs fine for me, as do the two subsequent steps (entering the directory and installing.)


#7

I was able to give it another shot this evening… Im not sure how I had the glitch. But the scrypt was broken on the webpage for me. Also shown in what I copy and pasted above. The comand was not single line
“git clone https://github.com/adafruit/Adafruit_Python_SSD1306.git
was showing up as 2 lines. Maybe I somehow had my webbrowser to narrow of view? But all is good. And Im glad. It was just weird that I could not get that working. ThankYou for the pointers. Nice to have this working.