Adafruit Verter


#1

I’ve added the Verter to my picade so I can provide 12v to the case (to power LEDs) and step it down to 5v.

Powering it on worked first time, no problem, but since shutting the picade down and unplugging the Verter it doesn’t want to run again. I.e. the light doesn’t come on anymore when powering from the 12v supply.

Using a multimeter there’s definitely continuity through the Verter board and I found the adaptor to produce slightly over 12v (12.4v). The Verter states it’ll handle up to 12v, but would the .4 extra be enough for it not to work?


#2

Have to ask the obvious question, how accurate is your multi meter? If was inexpensive it may not be all that accurate. Maybe its more than 12.4? Or less?
Something else to keep in mind is if that measurement was taken with no load it may read high. Depends on the quality of the power supply and what regulation it has built in.
All that aside, If 12.4 was too much, I would have thought it would fail right away? I’d double check your wiring / hookup. Can you measure 12V at the input terminals of the verter board?


#3

So I found some more info. The TPS63060 chip on the adafruit verter is rated max 12v and switch current limit at 2.25A (I’m not sure what switch current limit means though).

The power supply I’m using is 12v 3A. I’m definitely getting 12.5v out of it. However I measured over 7A coming out of it, WTF! It’s the first time I’m using a multimeter really, but is that correct?

Maybe the power supply is too much for the verter?


#4

Switch current is the current supplied on the 5V side, the max load current it can supply.

Sounds like you have your meter misconfigured for measuring amps. There should be a specific jack that you plug the red test lead into to measure current. Then put your meter in series with the load, not in parallel like you do when measuring volts.

The power supply will only supply what current is needed by the load. The 3A rating is an up to 3A. It could output just milliamps depending on the load. With no load there will be zero current out.

If the verter has a hard limit of 12V and your supply is 12.5V, its conceivable that it is too much. And that it may have damaged the verter.


#5

Thanks @alphanumeric, I really appreciate the advice! I think I’ll ask Adafruit support if they think the power supply is outputting too much voltage.

Thanks


#6

This will likely work though, https://shop.pimoroni.com/products/wide-input-shim?variant=2168104321034
Up to 16V in and up to 2A out on the 5V side. Assuming 2A is enough to power the Picade?
With a little work it could be wired up without having to solder it right to the Pi’s GPIO header.


#7

Yeah, saw that yesterday, cheers! 2A should be enough for the picade unless you’re overclocking it. I have some 3.5mm block terminal connectors which should fit on the input.

Just for reference, I tried connecting a 9v battery to the inputs and the light still doesn’t come on. What is strange is if I connect the verter to the picade xHat and power the picade via the mini USB the light comes on, so something seems to be working in it. I have a feeling whatever I did might have broken it :(

Adafruit sell a UBEC converter but I’d rather have the pimoroni support for the help ;)


#8

Yeah I saw a link to that UBEC one in the description for the verter. I have half a dozen or so of Adafruits Powerboost 1000c’s on the go here. Haven’t had any problems with those. Those are 5V in 5V out though, battery power for the Pi.

The LED on the verter is likely on the output side, its getting back powered by the picade hat. A false indication caused by 5V coming in the output terminals.