Airdac speaker phat questions


#1

I have my speaker phat working over airplay with your one line installer but a couple of things have come to my attention.

Firstly the vu meter is not working. Is this expected behaviour?

Secondly I can now not play mp3 files normally. Is this expected? If not how can I change it back so I just have a normal speaker phat which I can play mp3’s off?

Hope I am not being to much of a noob!

p.s. See you at pi party!!!


#2

I think there is currnently an issue with the vu meters when playing through airplay, which we are looking into.

… we are using a pre-compiled version of shairport-sync that is part of raspbian testing (so ahead of debian/raspbian ‘stretch’) and it’s possible that the most recent push has broken something.

you can disable the shairport-sync service, or uninstall it altogether, though from what we observed today if what you want is to play files locally then playback+vu will work regardless of the service running or not.


#3

Thank you

However when I play a file through vlc it says

Audio output failed:
The audio device “default” could not be used:

No such file or directory.

Any ideas?


#4

I have also tried reinstalling speaker phat through the new interface you showed of bilge tank today and I still get the same error


#5

I’ll have to check it to be sure… can’t say I have been testing on the latest Raspbian image much - we were discussing this right now in our slack channel, it could possibly be some OS-level change.


#6

Ok so i run both scripts a few more times andnow nothing works. HELP!


#7

it works here on jessie lite… to be honest I have never tried it in Raspbian full, cause there is little point throwing THAT kitchen sink in for an airplay speaker, is that Jessie Full (with Pixel) you are running?


#8

Yes I will try again soon


#9

Right so I have tried again with the surface script and it now doesn’t show up on my phone so is there an update to shairpoint sync that could be affecting the script?

I have also just tried speaker phat install again and nothing happened there I just got the same error


#10

what do you call the surface script?


#11

I mean Airdac script


#12

hum, as long as your Pi is on the same network as your phone then you should see it as an airplay output.

I’ll have to try it against a full raspbian image - @sandyjmacdonald and I certainly struggled to get the VU meter going yesterday in that environment - but audio was working fine.

In the meantime, you could try option 1 - pHAT DAC - in the airplay insaller, which may cause you less trouble but won’t support the VU LEDs. Or use a fresh Raspbian Jesie Lite image which, at least at my end, seems to work (including VU for Speaker pHAT and pHAT BEAT).


#13

interestingly ‘default’ is the placeholder name in the asound.conf so I’m wondering if the value replacement that the script attempts (for Speaker pHAT and pHAT BEAT) is failing for you for some reasons.

… check /etc/asound.conf and verify that the output_device value under the pivumeter scope corresponds to your device.


#14

pcm_scope.pivumeter {
type pivumeter
decay_ms 500
peak_ms 400
brightness 128
output_device speaker-phat
}

airplay is now working but no vu and still same error when I try to play an mp3


#15

So when I play an mp3 through command line with mpg321

So this is the readout

High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2, and 3.
Version 0.3.2-1 (2012/03/25). Written and copyrights by Joe Drew,
now maintained by Nanakos Chrysostomos and others.
Uses code from various people. See ‘README’ for more!
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK!

Playing MPEG stream from Beethoven_fith_symphony.mp3 …
MPEG 1.0 layer III, 128 kbit/s, 44100 Hz joint-stereo
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
ALSA lib pcm_meter.c:678:(snd_pcm_meter_add_scope_conf) Cannot open shared library /usr/local/lib/libpivumeter.so

Does that shed any light?


#16

I’m not sure to be honest. Just tried with mpg321 here to be sure and it works perfectly.

just to clarify, what Pi is this on? and this is with Jessie Pixel, not Lite, correct? did the compilation process of libpivumeter fail in any way? and if you airplay you get sounds but no VU (but sounds work)?

… if you are in at the weekend / Pi Party, come and see me/us… perhaps you can bring along that SD so I can check a few things. The mp3 you are using could be useful as well, if that is OK for you to leave a copy with us.

I’m in the process of assembling a few test files to try to channel troubleshooting meaningfully and I’ll let you know when they are up and how to use them.


#17

this is on a pi 2 running the latest pixel.

I am at pi party tommorrow and I will be more than happy to bring the sd card.

I am just using bethovens 5th symphony as a test mp3 so it should be fine to copy

Before installing the airdac script my pi worked fine with speaker phat so I am not sure what happened!

Through airplay I get sound but no vu and I can not play mp3’s

I do not think there was a failure in the install of libpivumeter

Ok see you tomorrow (just look out for a teenager wearing a black raspberry pi t-shirt


#18

I will also bring a speaker phat with me which has been soldered up


#19


#20

Hey @RogueM,

After seeing you today I have made a fresh install of Jessie lite and have run the installer. The installer runs I see airplay on my phone. I connect and then nothing no audio or vu at all. No idea what is going on!