Automation Hat Does Not Play Well with Adafruit Servo Hat


#1

I have used both of these hats separately, but when I try to use them together I don’t get any further than the rainbow screen. I’ve checked the I2C addresses (separately) and there are no conflicts. Any ideas on what is going on? I’m using a Raspberry Pi Model 3B with the 2.5A power supply.


#2

How have you wired both HATs to your Pi?

A rainbow screen is an unusual outcome from permutations of HATs, and might mean anything from undervoltage (could be a short, but it’s hard to picture how that might happen) or potentially an issue reading the HAT EEPROMs on each board.


#3

The servo hat is directly plugged into the Pi. I soldered a stacking header and the right angle male servo headers to the hat to allow the Automation hat to be installed. The Automation hat is then plugged into the servo hat. I used brass standoffs to secure the hats.
I’ve tested the hats individually and together, with and without the brass stand offs, as well as measuring the voltages on the boards. In all cases the voltages read 3.3V and 5.5V. I experience the stalled rainbow screen only when both hats are installed.


#4

I forgot to mention that I have tried this with 2 Pis, both with upgraded software.


#5

See my post on this issue. I have the same problem. Temporary fix is to use jumper wires to connect only Ground, +5, +3.3, SDA and SCL . between the automation hat and your RPi stack. There seems to be a conflict. I was able to run both hats
.


#6

The ID_SD and ID_SC signals were the culprits! I clipped these pins on an extension header, and all works flawlessly.


#7

I suspected as much- but I’ve never seen it actually happen! I wonder what’s unique about these two boards that reading the EEPROM causes a lockup.


#8

Have you tried to have both Hats stacked at the same time? I have tried several boards with the same problem.
Clipping pins 27 and 28 causes the problem to go away regardless of whose Hats are stacked. I now have 3 Hats stacked and all perform as spec’d Automation Hat, Adafruit Servo and Motor Hats were the ones I use. All have the EPROM chips on them.


#9

Yes I have. I’m using them together without any problems.


#10

Would be interesting to know what version(s) of Raspbian you’re both running and whether there’s a particular version in which two EEPROMs cause a lockup.

I’ve never had it happen here, either, but since they are read at boot I could certainly imagine it happening.


#11

Both of my Raspberrys are running Raspbian GNU/Linux, version 9.