Badger2040 missing files

After updating my badger2040 and connecting to Thonny I seem to only have a main.py and not the other files I should have. Any ideas?

Thanks

The other files are created when you first run the relevant examples.

Hi @hel (sorry to revive an old post, but it seemed a good fit)

my badger seemed to be crashing when I tried to update the uf2, so I did the factory reset (flash_nuke.uf2). Then I flashed the Badger uf2 (pimoroni-badger2040-v1.19.6-micropython.uf2), but now I have no files at all.

Which examples? I looked through pimoroni-pico/micropython/examples/badger2040 at main · pimoroni/pimoroni-pico · GitHub I saw that boot.py creates main.py, but it only gets one line

import _launcher

which doesn’t work…

I’m sure I’m missing something basic, I’ve run all the examples in that folder, with mixed results, some work, others just fail.

How do I get it back to “as new”?

Thanks

Try using the 1.19.7 image! The 1.19.6 Badger image was missing vital files.

Direct link

1 Like

Awesome! That worked. Thanks!

1 Like