Blinkt not working


#1

Hello everyone. I bought a BLINKT! a couple of days ago and decided to test it.

I have my Raspberry Pi Zero W running, and I have installed the python module to have blinkt running from a python script.

I am using a male Hammer Header which I have pushed down to the GPIO (as far as I can see all the pins are touching the board), and I have then pushed the Blinkt unit on the pinouts (no soldering, just pushing it through).

As far as I can tell the software side of things is fine. I’ve updated and upgraded everything. The python script I am using seems to be importing all modules correctly, and does not complain when it runs, only there’s no activity on the LEDs.

Is there any way to check whether the header or the BLINKT! unit is working correctly?


#2

Whit the Pi Zero’s ports facing you, USB HDMI etc. Are the letters on the Blinkt readable, right side up? The B should be on the PIN 1 end of the GPIO.


#3

Yes, that’s the case. BLINKT! can be read in the right way when facing the ports.


#4

Could you post i) a photo of the underside of the Pi, so that we can see how the header is fitted, and ii) the code that you’re using, please?


#5

Of course:

Here’s the image:

Let me now if you would prefer to look at it without the PiBow.

The code is the following:

from blinkt import set_pixel, set_brightness, show, clear
import time

set_brightness(0.5)

while True:
    for i in range(8):
        clear()
        set_pixel(i, 255, 0, 0)
        show()
        print("blink!")
        time.sleep(0.05)

#6

Pictures for the top:



#7

The Blinkt! doesn’t look properly pushed onto the pins. It should be down below the top layer of the Pibow. Press it down firmly.


#8

That’s right, I was afraid of pushing it further since there was a lot of resistance but I managed to push Blinkt! onto the pins. Now it’s touching the top layer of the Pibow. However, it is still not working.


#9

What happens when you run the code?


#10

It prints out “blink!” in a loop until I kill it.


#11

Have you tried the example scripts? Do they also not work?


#12

Tried half a dozen of them, none works.


#13

Weird. Did you hammer in the header, or just push it in?


#14

Hammered it all the way in. The black part of the header is touching the board and the little pins on the back seem to be all the way in.



#15

I’ve also re-installed the OS just to make sure nothing went wrong with the drivers and installed the Blinkt python libraries from a fresh Raspbian installation, but the Blinkt! unit is still not working.


#16

Looking at the Pinout, https://pinout.xyz/pinout/blinkt# it doesn’t use i2c, so running i2c detect won’t help. Not sure how you check it? Sounds like its DOA though. Unfortunate but it happens occasionally.


#17

DOA is dead on arrival, right? In that case, what would be the best thing to do?


#18

When did you buy it, and from who? If from Pimoroni and less than 30 days ago, click the contact us link at the bottom of the main page. Then see what they say. I’d put a link to this thread in that tech support e-mail.


#19

Yes, it was from Pimoroni, only 2 weeks ago.

I’ll get in touch with them, thanks!


#20

Hi,
sorry for bumping and old thread but I seem to be having the same problem with my blinkt unit.

I am running the kali-pi OS (and am aware that upon downloading the blinkt packages there is an error telling me the build is experimental for this distro), however python seems to have no problems with processing the script, in either p1, p2 or p3. I have also tried running various example scripts and they all run, but provide no output on my blinkt unit.

I have tried updating various packages including RPi.GPIO and have also ran the curl command, of which I already had many of the necessary packages installed and updated. I did however notice that while attempting to download raspi-gpio, it was retrieving the armhf package and not the armel one and so was unable to install.

I am using the hammer header, which is properly connected to the rpi (and the blinkt unit is facing the right direction [rounded edges towards the back of the rpi, ‘blinkt’ readable from the HDM, USB side]).

Not really sure what to try next, other than installing raspbian, which I don’t really want to have to do just to test this functionality…

Anyone have any ideas?

Thanks