Blinkt not working properly on Pi Zero


#1

I just got my Blinkt, I have soldered the header pins on PiZero 1.3 and connected the Blinkt. I tried to light up the LEDs using the tutorial, but looks like some LEDs are lighting up and some are not lighting up randomly, even the colors are not correct. Is it possible that I messed up soldering, or is Blinkt broken?


#2

Is your blinkt firmly snapped on top of the Pi? Check your soldering on the pins highlighted in the following page as well:

Last, what is the output of pip list, specifically what version of blinkt and RPi.GPIO is reported as installed?


#3

Thanks for the response.
I have checked the soldering, it all looks good.
my blinkt version is 0.1.0 and RPi.GPIO version is 0.6.2
here is the pip list output:
pi@raspberrypi:~ $ pip list
argparse (1.2.1)
blinkt (0.1.0)
chardet (2.3.0)
colorama (0.3.2)
gpiozero (1.2.0)
html5lib (0.999)
lxkeymap (0.1)
mcpi (0.1.1)
ndg-httpsclient (0.3.2)
numpy (1.8.2)
oauth (1.0.1)
picamera (1.10)
pifacecommon (4.2.1)
pifacedigitalio (3.1.0)
pigpio (1.30)
Pillow (2.6.1)
pip (1.5.6)
psutil (2.1.1)
pyasn1 (0.1.7)
pycups (1.9.63)
pygame (1.9.2a0)
pygobject (3.14.0)
pyOpenSSL (0.13.1)
pyserial (2.6)
python-apt (0.9.3.12)
requests (2.4.3)
RPi.GPIO (0.6.2)
RTIMULib (7.2.1)
sense-hat (2.1.0)
setuptools (5.5.1)
six (1.8.0)
spidev (3.0)
tweepy (2.3)
urllib3 (1.9.1)
wheel (0.24.0)
wsgiref (0.1.2)


#4

On the software side it looks good, but I need to know how you connect your blinkt to the Pi, jumper wires into the female header often leads to many a woes and before we consider the blinkt DOA you should try to eliminate all potential points of failure.


#5

I’m using header pins only, not any jumper wires.


#6

it’s a long shot but I don’t think your system is fully up-to-date (gpiozero 1.2.0 is a bit outdated).

Try:

sudo apt-get update && sudo apt-get upgrade
  • reboot. If it still fails after that then shoot an email to support@pimoroni.com and they’ll sort you out a replacement.

#7

Sorry my bad, soldering was not done properly, i fixed it and it works now!

Thanks for all the support!