Blinkt raspberrypi zeroW not working

Today i tried to use the Blinkt hat on my raspberrypi zeroW, but the lights are not lighting up.

I can use the commands just fine, and when checking the pixels after setting them with blink.get_pixel(x)
it returns the right values but after typing nothing happens.

I also updated and upgraded the software on the pi, and tried some preinstalled scripts for the pi.

Could it be a problem with soldering? The pi seems to communicate just fine with the blink, and my Explorer pHat also seems to work fine.

It only uses 4 pins

I would think they are working if you can talk to it and read back the values? Can’t hurt to look at those pins though, soldering wise.
I have mine on my Pi 4B showing CPU load. I had originally set it up to show CPU temperature. But after I switched my Fan Shim to continuous run, it just sat there showing ~40c all day. So I decide to switch functions. Anyway mine is working just fine in Buster. I mention this because there have been some issues with other Hats and pHats in Buster.

Did you have the explorer pHat installed and running prior to installing the Blinkt? It also uses pins 16 and 18 so it may be a software conflict. You may have to start over with a clean Buster image and just install the Blinkt software,