Boot issues

Raspberry pi won’t boot anything?

Okay, so the title isn’t entirely true, it will boot
noobs and install any os within noobs and it runs
well from the USB stick I am using.
The problem comes if I try to use any distro not
included in noobs, I’v used Etcher, Rufus and
Win32DiskImager, none will boot. Iv tested with
4 or 5 different OS Isos but zipped and unzipped
and I’m not sure what else to try.
I know raspberry pis used to have to boot from
SD card but the 3b+ and 4s are updated to boot
from USB now. And the boot bit has been set to
boot USB too (shouldn’t be needed anymore but
set it anyway to just see)
What else can I do to get something other than
noobs and Raspian on my pi?

What model Pi? The 4B doesn’t support Boot from USB yet. According to what is posted on the Pi Foundation Forum. It will be enabled at some point but they have to sort some things out first.
And what Distro’s have you tried?
Any OS other than the latest Raspbian has to be updated to boot on a Pi 4B. New firmware etc. This happens every time a new model is released. Its why a new version of Raspbian is released at the same time. Those included on the newest version of NOOBS, the one for the Pi 4 have been updated. Anything else is a roll the dice.

It’s a 3b+ so USB booting shouldn’t be an issue. I have tried Ubuntu, Kali and Parrot. Noobs works perfectly.

Ok,3B it is. I’ve only ever run Raspbian on my Pi’s so I’m not sure what help I can be. I ran NOOBS maybe once many moons ago. I didn’t see the point of using it as I only ever run Raspbian. I’m not knocking it, its just not for me.