Connecting - error while loading shared libraries: libboost_filesystem.so.1.50.0


#1

Running Jessie and it just says it’s connecting. Run flotilla on the CLI and only get this error - flotilla: error while loading shared libraries: libboost_filesystem.so.1.50.0: cannot open shared object file: No such file or directory

All up to date already followed a couple of posts on here but no luck.


#2

libboost-filesystem1.50.0 shouldn’t be needed on Jessie (libboost-filesystem1.55.0 is used instead).

What do you mean by running flotilla on the CLI, call /usr/bin/flotilla manually?


#3


#4

Getting exactly the same here. When I connect up using Rockpool from the menus it just says “Searching for Flotilla…” but when I plug stuff in the lights come on, and I get the talking light slowly flashing.

When I run flotilla from Terminal, I get the same shared libraries error message. This is a vanilla Raspbian install which has ran the apt-get upgrade as recommended before cloning from github and running the install.


#5

Same as mine tottally fresh download of jessie and completly fresh install, all updates and upgrades done followed instruction on Flotilla/start/


Mini Starter Kit Delivery
Struggling to connect using jessie
#6
sudo apt-get install libboost-system1.50.0 libboost-filesystem1.50.0 libboost-program-options1.50.0

… that should get you going.


#7

Works for me! Thank you!


#8

AWESOME worked BOOM!!!