Struggling to connect using jessie


#1

I am using a PI B series 2 with Jessie.
Have ran sudo apt-get update and then upgrade.
Have down the git clone …flotilla-offline and sudo ./install
My dock, barometer and light module are all connected. Dock has power ,hello and talking LEDs lit.

I run flotilla rock pool from the programming menu, get a message pick your dock and searching for flotilla message displayed .
This eventually completes and I am left with a display of finished.

Looking through the other posts if I type in
Cat /etc/os-release PRETTY_NAME is Jessie.

I have typed in flotilla in a terminal window and had an error message regarding libboost-systems.50.0 which I have installed and rebooted.

I now get an error message regarding libboost_filesystem.so.1.50.0 so just to try something I ran
Sudo apt-get install libboost_filesystem.so.1.50.0 to get an error message unable to locate package.

Any ideas what to try next?


#2

Same here! Tried all the suggestions on the forum…


#3

I am getting the same issues too, i did follow the other thread to update various things but still getting the message connecting!


#4

I bought a Pi 2 install Jessie as per instructions and nothing?


#5

see this topic: Connecting - error while loading shared libraries: libboost_filesystem.so.1.50.0


#6

I have installed the libraries as per the post and rebooted.

now when I type flotilla into a terminal window I get an error message unable to open pid file.
rockpool searched for flotilla and then displays finished. no dock displayed.

if i click connect in rockpool to 127.0.0.1 then it looks like it is working, i.e. with rockpool connected and the temparature, barometer connected i can display temperature and pressure within the browser.

is there some documentation I have not found on how to use flotilla and the scaling of the sensors etc?

i currently have a temperature output of 339 and pressure of 592.


#7

The latest flotilla runs as a single instance daemon, and will be running on booting up your Pi, so that message is just telling you another is already running basically.

Haven’t looked into the datasheets yet but you can look at the cookbook at
http://flotil.la/cookbook there is a recipe that will output the readings in Celcius and Pascals respectively.

… best to start a different topic if you have questions about operation of the modules, answers will be useful to more than just who ran into a problem with Jessie ;-)