Flotilla not connecting


#1

Hello All. I’m having a problem connecting Flotilla, I can’t get passed a message saying ‘Connecting’. Any ideas how to progress from here?

Thanks


#2

Summoning @gadgetoid - we’ll get you sorted out. :-)


#3

Thanks, I’d be grateful for any help getting started.


#4

Zoiks. What have you set up so far?

The Rockpool interface will attempt to connect to the Flotilla Daemon, a process that runs in the background and actually handles talking to the dock.

If you go into Terminal on your Pi and run:

flotilla

What do you see?


#5

Hi, it says “flotilla: error while loading shared libraries: libboost_system.so.1.55.0: cannot open shared object file. No such file or directory”

I’ve installed flotilla-offline again, it says it’s already been installed.


#6

Ah, is this on Raspbian Jessie Lite, or Wheezy?

It might be related to: RASPBIAN JESSIE LITE - Error running 'flotilla': Solved?

And fixable by:

sudo apt-get update
sudo apt-get install libboost-system1.55.0

Otherwise I need to get the Wheezy binary and auto-installer working.


#7

To be honest I’m not sure. I’ve downloaded Rasbian Jessie, but it won’t open. I’ll try your suggested fix and get back to you.


#8

Hello, I’ve tried the fix, but still no luck. I’d be grateful for any further guidance.


#9

Did apt install when you ran that fix?

Did you try running flotilla again to see if it works.

If it does, reboot your Pi and the daemon should fire up.

Oh and can you run:

cat /etc/os-release

And let me know if it says (wheezy) or (jessie) at the end of the PRETTY_NAME line.


#10

Hi, when I ran sudo apt-get install libboost-system1.55.0, I got the message
E: Unable to locate package libboost-system1.55.0
E: Couldn’t find any package by regex 'libboost-system1.55.0"

When I entered cat /etc/os-release, the pretty name was wheezy

I hope all this make sense to you!!!


#11

Aha! Yes, it does! I’ll have a fix for you momentarily.


#12

Okay, you’ll need to navigate into the Flotilla-Offline directory, I’m going to guess it’s in your home dir so you can probably do:

cd ~/flotilla-offline
git pull
sudo cp flotilla-wheezy /usr/bin/flotilla
sudo chmod +x /usr/bin/flotilla
flotilla

I’ll make the installer Wheezy-aware so this doesn’t happen in future.


#13

You also need to:

sudo apt-get update
sudo apt-get install libboost-system1.50.0

(instead of libboost-system1.55.0)


#14

That’s done the trick!! Thank you both for your help, much appreciated.