Display HAT Mini Pi Zero W Black Screen

Hello Everyone,

As a software developer new to electronics, I’ve been working with a Raspberry Pi Zero W, interacting via SSH. All necessary libraries (PIL, numpy, spidev) have been installed as per the GitHub repository’s instructions. SPI is activated, and the correct model for the Display HAT Mini is chosen.

Despite these steps, the backlight of the display comes on, but the screen remains black. The display is connected through the GPIO pins.
The Display =
A generous 2.0" (320 x 240) IPS LCD display for Raspberry Pi with lots of tasty baked in functionality.

Your expert advice to help resolve this problem would be greatly appreciated.

Thank you in advance.

Did the Pi Zero come with the header pre soldered or did you solder it on?
It’s one of those questions you have to ask.
Have you run the installer?
What python example(s) have you tried?

pimoroni/displayhatmini-python: Python library for the Pimoroni Display HAT Mini (github.com)

Hello Alpha

No i added the solderless pins by taping hammer
they all look good
i did run the installer and the examples

and they seem running from the SSH but i go nothing on display

As for the light pixel on display work

Ok, sounds like there is a fault somewhere.
It could be the display or the Pi though?
Do you have another Pi to test the display on?
Tech support is likely going to want to see a picture of the hammer header install.

I tested
with another pi and different hat this time the scroll hat HD

and nothing but i used same system and i re installed it too i did everything

pi@raspberrypi:~/scroll-phat-hd/examples $ i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – – – – – – – – – – – – – –
70: – – – – – – – –

What Pi, and what Hat combo were in play when you ran i2c detetct?

The Display Hat Mini uses SPI, and won’t be detected via i2c detect.
And the Scroll pHat uses i2c, that won’t help you test the SPI connection.

My only connection i have for moment is throw the GPIO pins for both of Display and the scroll

i tried different ones but i have same output The scroll nothing running
the display i can send signal to the light
and i guess one of the buttons only working

Could it be The OS or package missing?
its been two days I’m trying to debug but still same

This is the Scroll hat HD When i run an example =

Traceback (most recent call last):
File “/home/pi/scroll-phat-hd/examples/plasma.py”, line 30, in
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/init.py”, line 179, in show
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/init.py”, line 71, in setup
display = is31fl3731.IS31FL3731(
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/is31fl3731.py”, line 66, in init
raise e
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/is31fl3731.py”, line 62, in init
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/is31fl3731.py”, line 129, in reset
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/is31fl3731.py”, line 135, in sleep
return self._i2c_write(_SHUTDOWN_REGISTER, not value, bank=_CONFIG_BANK)
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/is31fl3731.py”, line 157, in _i2c_write
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/is31fl3731.py”, line 148, in set_bank self._i2c_write(_BANK_ADDRESS, bank)
File “/usr/local/lib/python3.9/dist-packages/scrollphathd/is31fl3731.py”, line 158, in _i2c_write
self.i2c.write_byte_data(self.address, register, value)
File “/usr/local/lib/python3.9/dist-packages/smbus2/smbus2.py”, line 455, in write_byte_data
ioctl(self.fd, I2C_SMBUS, msg)
OSError: [Errno 121] Remote I/O error

Could you post pictures of the hammer header install?
My gut feeling is there are connection issues.
The remote IO error sugest’s that.
I’m going to ping Hel Gibbons on this one, she works for Pimoroni

What version of Pi OS is installed?
If it’s Pi OS Lite, there may be something needed missing?
Are i2c and SPI enabled via raspberry Pi config?

For moment I’m using the Pi Os desktop version
before that i had the Pi Os Lite

The i2c and SPI were on i activate them from Config

Ok, that all looks good.
Thanks for taking the time to post those pictures
Might be time to contact tech support via e-mail.
Contact Us for Raspberry Pi Technical Support - Pimoroni

1 Like

Is there a followup to this? Im experience the same problem. No screen. Tried different pi’s and os with the provided steps online.

1 Like

unfortunately i could not solve it and saved it for later to test and till now its in my inventory , The Team and people in forms they provided all help but all things i tried got me in same result, Hope you will find solution , If so Please Mention me so i follow up.

Best of luck