Grow Hat Mini install not working. No LCD display

Hi, first post.

I bought a Raspberry Pi Zero WH with Grow Hat Mini, followed the install instructions and no matter which method I use I still don’t seem to have a working Grow Hat.

The service is running but there is nothing on the display. The script seems to give a correct reading which is promising. But if I try to run the it fails and asks me to install numerous packages, and once they’re installed it still fails with this error:-

Woah there, suitable gpiochip not found!
/dev/gpiochip0: 9 is an int and has been skipped, did you mean “PIN9” or “GPIO9”?

I am using the 32-bit legacy OS with desktop. I have tried an older version called Buster but I still ended up with the same issues.

Any help much appreciated!

Funnily enough I’ve been poking at this myself recently, because of a similar problem on Discord.

The problem is that the Grow library (and subrequirements like the display stuff) is all in a state of flux dealing with both GPIO and python changes that have arrived with the Pi5 & Bookworm, and things don’t work as smoothly as they used to.

The procedure I went through on a Zero WH that resulted in a functioning display was:

  • Install Legacy OS
  • Run CURL installer (curl -sSL | bash)
    (this installer will end abruptly complaining about not running under root; don’t worry!)
  • Checkout the grow hat repo (git clone and move into this directory (cd grow-python)
  • Switch to a slightly older version of that repo, from before they broke Bullseye compatablity (git checkout 581a025)
  • Run the installer (sudo ./
  • Regress the display library (sudo pip install st7735==0.0.5)

That should then result in a fully functional Grow (or at least, it did for me)


Thanks ahnlak! That has fixed it, very much appreciated!

Just off to kill some plants :-D

I signed up here just to thank you for this solution. I too was having issues with all the recent changes, and I followed your instructions and now my new Grow hat works perfectly, it even set up the boot service for me. Hopefully at some point this all gets rolled into the official instructions so others can get this working too.

1 Like

Glad to hear it! I’ve raised an issue, so once I know the direction they’re thinking of going I might try and roll some form of these instructions into a PR for them so we can fix it properly :)

1 Like

Hi, this is my first post and just wanted to say thanks. I had a very disappointed 9 year old who was upset we couldn’t set this up. This has fixed it, thanks for saving the day I’ve been pulling my hair out since Christmas Day!!

Thanks for this! Wish they’d maintain their code a bit better…