Update "Getting Started with Grow"


This week I just got a Grow Hat Mini that I assembled with a Raspberry PI 4.

Installed latest Raspberry OS but the one line installation as described in the Getting Started with Grow documentation does not work.

The only way I found to fix all the issues and follow the instructions was by installing Raspberry PI OS Legacy.

This documentation should be updated to reflect this detail so new buyers can have a first good experience.


I’m guessing you hit an issue similar to this.

St7789 install error with Bookworm? - Support - Pimoroni Buccaneers

Installing the Weather HAT Python library fails - Support - Pimoroni Buccaneers

I reverted to Legacy on my Pi 400 so the installers would “just work”, without having to resort to the “new” virtual environment install procedures.

Thanks Kerry.

Yeap, that’s what I did.

My main point here is the update of the documentation/tutorial so others don’t spend time with this issue (I spent a couple of hours until I found your posts and tried the revert to legacy).


This new install procedure is going to make things a pain for a lot of retailers.
Especially the “if using Bookwork” do this, “if not” do this part. If it ends up being that way? I’m just an enthusiast with minimal software shills.

The error will link you to the answer, it’s just a case of can you figure out the answer. ;)

Yes, hopefully we’ll have a straightforward install procedure we can recommend soon that will make things work more smoothly with Bookworm.

@renato0307 @alphanumeric hi folks – I was glad to see your post. I just hit this problem. I tried following the threads mentioned as well as your suggestions to revert to Legacy OS. So I tried the 32 and 64 bit versions of Buster and Bullseye but neither worked. I had the script install everything and rebooted but the monitor wouldnt turn on. This week I actually asked the local retailer for an exchanged hat before I saw your posts. Now when I run the script I dont even get to the Examples prompt the Starting with Grow tutorial mentions. What I get is the ‘script should not be run as root’ prompt… i made sure i was switched out of root and i also tried running the install script in the service folder after downloading the code from github. no change. wondering if you all had advice?

I don’t unfortunately. I bought mine a while back, last year some time. It worked then with no issues. I’d have to boot it up to see what OS it’s running. I’ll try and do that some time this week. I set it all up when I got it, but never actually put it in use. The plants I want to use it with I haven’t got around to buying yet.
I’ll also image a spare SD card with Legacy, and run the installer etc, and see what happens. Might be a few days before that happens, just so you know.