Grow HAT mini code unstable?

I got my grow hat today together with a pi zero wh.
I installed the code using the curl program. And checked after rebooting the test lcd python program. The ground was soaking up meanwhile for the chili seeds, so the moisture probed where not attached.
The “Hello world” was show so this looked okay.
Then, Pimoff, I connected the three moisture probes and booted the pi. Nothing was show, although I let the curl script install the the service.
Checked with “top” if the service was running. It was…
Rebooted ones more and the where some reading!
But… the buttons didn’t work.
Service stop, service start. No succes. Service off and check lcd test program. No hello world anymore. Rebooted ones more, and the values where shown and buttons seems to work… for a while.

So what is wrong with my grow hat setup? Is it hardware is it the software? What can I check more?

Just to confirm, you ran curl -sSL | bash?
Then said "yes’ to install the examples?
And “yes” to install the plant monitor as a service?

Also is the Grow pHat firmly attached to the pi?

Yes, yes and yes. :-/

Fresh new install of PiOS on that Pi Zero?

Fresh install but on a different pi zero. Will test this.

On another Pi Zero shouldn’t matter. Just wanted to rule out other installed software and or hardware maybe messing things up.

Re-installed OS on Pi (was not necessary but did it anyway).
Update an upgrade.
last line of curl command are:

zip_safe flag not set; analyzing archive contents...


Setting up i2c and SPI..

Backing up /boot/config.txt to /boot/config.preinstall-growhat-2020-09-26-22-38-29.txt

Adding dtoverlay=spi0-cs,cs0_pin=14 # Re-assign CS0 from BCM 8 so that Grow can use it to /boot/config.txt

Would you like to copy examples to /home/pi/Pimoroni/growhat? [y/N] y

Copying examples to /home/pi/Pimoroni/growhat

Grow includes a service that runs on boot and monitors your plants.

Would you like to install the service? [y/N] y

Copying icons to /usr/share/grow-monitor...

Installing grow-monitor to /usr/bin/grow-monitor...

Installing settings to /etc/default/grow...

Installing systemd service...

Created symlink /etc/systemd/system/ → /etc/systemd/system/grow-monitor.service.

To see grow debug output, run: "journalctl --no-pager --unit grow-monitor"

All done!

If this is your first time installing you should reboot for hardware changes to take effect.

Find uninstall steps in /home/pi/Pimoroni/growhat/

Some changes made to your system require

your computer to reboot to take effect.

Would you like to reboot now? [y/N] y

It is a bit of a pain to start over, but I have done it in the past just to rule out a glitch happening during the process the first time around.
Big question now is, is it working?

First: no
Then removed the 10mm stand-offs.
It looks like it works, but screen if weird when pressing buttons. And pressing buttons does nothing now.

Yeah, something is messed up? I don’t know what though?
I don’t own a Grow just so you know. Might be time to do the following.

Hi there, I just got it to work - after a bit of back and forth. Turns out, my old RaspiPi OS wasn’t working, I then did a new NOOB using RaspberryPiImmage-Manager and chose Raspberry Pi OS 32bit, and everthing went flawless after that!
So, it’s a bit of pain but perhaps consider downloading and installing a new/latest OS.
(I followed Pimoroni instructions to a T’ on their web site and that using that new OS, was flawless process. Grow is now happily working/growing)