Grow not working after install

Today I installed a new version of Raspbian, did an update and upgrade and followed the instructions on the Getting Started with Grow tutorial, but I don’t seem to have anything showing up on the little screen. The tutorial leads me to believe that it should just automatically work after an install. It looks like the backlight is on for the screen, and perhaps flickering, but I’m not sure how normal/abnormal that is.

I had a go at stopping and starting the service and rebooting etc., but I’ve not had any luck there.

I also tried having a look at the examples in /Pimoroni/growhat/examples/advanced and I’m not getting anything when I run the script, and when I run the script I’m getting readings of 0 on all three sensors consistently, which seems a little odd to me too.

Any advice of things I could check would be greatly appreciated as I’m a little lost on where to look next.

1 Like

updating to new version isn’t always a good thing.grow might not be updated yet .try going back to old version ,to see if it works ,

I can give it a go, but I’m not sure what version of Raspbian would be the best relative to when Grow was released

and im not sure what version i used when i ran mine last summer .an older one for sure !