dot3k install not making happy :(


#1

Hi Pimoroni peeps
I have spent most of the evening trying to get the dot3k working, I have tried it on 2 pi’s and done 2 fresh installs but can’t get it working, prob something very trivial but i’m a n00b programer.
When I go to run a program I get this error:

  pi@raspberrypi ~/dot3k/python/examples/basic $ sudo ./hello_world.py
Traceback (most recent call last):
  File "./hello_world.py", line 3, in <module>
    import dot3k.lcd as lcd
  File "/usr/local/lib/python2.7/dist-packages/dot3k/lcd.py", line 1, in <module>
    import st7036
  File "/usr/local/lib/python2.7/dist-packages/st7036.py", line 4, in <module>
    import RPi.GPIO as GPIO
RuntimeError: This module can only be run on a Raspberry Pi!

Any help would be great I’m lost and sleepy so I have a look back in the morning.
Thanks
Peter


#2

The Pi 2 took the Pi community something by surprise- nobody was prepared for it, and it’s different enough that a lot of old Pi things simply don’t work.

RPi.GPIO is one of those things- it has become the cornerstone library for doing GPIO on the Pi, but the developer who maintains it has only evenings and weekends to bring it up to speed. Dot3k wont work until it’s updated, unfortunately, and the same applies to basically all Python-based GPIO on the Pi.

Watch this space for updates on what works and what doesn’t: Raspberry Pi 2- What works and what doesn’t!


#3

I tried it on a B+ and it wouldn’t work either, I think it was a slightly different error however. Thanks for the help I’ll keep an eye on the progress.


#4

ok Just swapped the SD card into the B+ and is working like a charm, thank you thank you


#5

Sorry it’s not working on the Pi 2 yet- I’m looking at a short term solution for it.