DOT3K - LCD not working


#1

Hi,

Love the Displaytron think it will be great when I get it all working.

The problem I am having is with the LCD displaying text and characters. Nothing happens. I can run the sample code fine and the backlights, bar graphs and joystick all work.

I have read about similar issues in another thread but I have tried on a model B and a model B+ and also started from scratch with a fresh copy of the latest Raspbian 31-01-15 image and only ran the Pimoroni dot3k install script and all produce the same results.

There are no error messages and the SPI and I2C elements all appear to be setup correctly.

I am now wondering if it just a faulty unit. Any advice gratefully received.

Thanks


#2

Sorry for the slow response!

It sounds very much like a faulty unit to me, particularly something wrong with the charge-pump circuit which means the controller in the LCD is working fine, but nothing will display on the LCD.

Take a look at the solder joints underneath, they should all be nice and shiny, is anything looking out of place? If you’re feeling brave and have a soldering iron you can try giving them a quick reflow- but don’t feel you have to!

If it’s DOA we’ll get you out a replacement, drop me a PM or email support with your order details.


#3

I have a new replacement DOT3K now and it’s all working lovely :-) Thanks for your help.


#4

Hi,
I have the same problem - the background colours change and the barograph works, but the LCD won’t display any text or characters.


#5

It’s possible that SPI isn’t enabled properly, or is wonky. Did you use the installer on-liner? Try this and if it doesn’t work then drop us an email to support and we should sort you out!

curl get.pimoroni.com/dot3k | bash

#6

Yes, that’s how I installed it.
I’ll contact support.
Thanks.


#7

Cheers! Stuff sent to support goes through the proper ticketing channels so we ( well, “I” ) don’t totally lose track of it or forget to inform the relevant people.


#8

Hey there! I do have similar problems with my dot3k … Backlight and Bargraph is working but no text is shown. I’m using a Raspberry Pi 2. I’ve also tried the dot3k on an B+ where everything’s working fine - so it can’t be a problem of the dot itself… I used the installer script on both Raspis… SPI is enabled…


#9

There’s definitely something odd going on periodically with the Pi 2 and SPI. Have you updated lately?

sudo apt-get update && sudo apt-get upgrade

Try also using raspi-config and enabling SPI again, just to be sure.

Are you using the same memory card in the Pi 2 as the B+ when testing? If nothing else works, I suspect this would be fixed by a fresh install of Raspbian, but I’d still really like to know why it keeps happening.


#10

Hey gadgetoid …

yes, I did an update and even a fresh install with the latest raspbian img (2015-05-05-raspbian)… I also tried to enable / disable devicetree… atm I am trying it with an older release (2015-01-31-raspbian) but same error…

Btw - I am using different SD-Cards (boths systems are up and running)… and yes, i tried to reenable SPI again…

I also don’t believe that it’s a problem of the Pi itself - the PiFace2 was running well when I tested it 2 months ago…


#11

Have you tried the PiFace since? Or any other SPI device/add-on board?

If it consistently works with your B+ then I suspect that there’s something minor up with your Pi 2. SPI aside, if BCM 8 or BCM 25 pins are dodgy, then it’s possible that Dot3k might not work, while another SPI-based board might.

Dot3k uses BCM 25 as the command/data switch, so if that’s stuck in one state the display might never get data or commands.


#12

Hm ok… have to check that out … I guess I try the PiFace again to see, if that still works… I’m now using the B+ with the dot3k… Trying to get that work with FHEM but running into some other problems now (I’m new to Python - so I have to figure out how to program a script which is able to “communicate” with FHEM in any way or a script where FHEM is able to send the display messages to) :D