Displayotron backlight problem


#1

Hi there,

I received my replacement Displayotron 3000 yesterday (Order #14859), but it seems this one is having backlight problems similar to the first, this time with the right-hand LED. Initially it worked fine but within a couple of hours the red element of the RGB had stopped working entirely. Pics here: (the effect is more pronounced in reality, and zeroing the HSV values makes no difference):

http://deskbound.org.uk/files/IMG_1282s.jpg

http://deskbound.org.uk/files/IMG_1283s.jpg

This has been tested on a Pi model A and a B+, with a fresh install of Raspbian (2014-09-09), following all the instructions on the dot3k GitHub page, and using a ModMyPi HQ 5V 2A power supply.

Much as I like the dot3k (it’s an LCD with RGB LEDs, what’s not to like?), two wonky ones in a row is a bit of a pain. Could you possibly organise a refund for me, please, and I’ll return this problem one.

Thanks in advance.


#2

Hi!

I’m very sorry to hear that :-( We think there may have been a bad batch of LEDs but are looking into it further.

I’ve refunded you the cost of the Dot3K and shipping for your order - thanks for getting in touch!


#3

That’s a real shame if you’ve had some dodgy LEDs, as the display is lovely.

Thank you for sorting the refund, it’s much appreciated. I’ll put the duff one in the post to you this afternoon.


#4

I’m having right right-hand red LED flickering on my otherwise superb DoT3K. (Order #15041 )

At first I thought it was because of a bad connection with the GPIO - the female header on the DoT3K is a lot shorter than on the Pibrella or PiLiter and I’m not convinced it makes a good connection on the Coupé cases.

However having removed the top layer of the Coupé and seated the DoT3K fully down on the pins, it still seems to flicker on the right-hand side when the background is set to red. So not a header height issue.

Shall I send this one back? (To Manton Street address?) It’s a wonderful product and I’m keen for a replacement rather than a refund.

Regarding the header, here’s a photo showing (top) comparison of header heights between Pibrella, PiLiter & DoT3K, and (bottom) showing the Model B (original) Coupé (all layers) with DoT3K fitted, lots of pin length exposed and only just seated on the pins.


#5

Hi! The headers are electrically good - we spent a lot of time testing and evaluating them. We specifically select the shallower style as it reduces insertion force and as such is easier to plug/unplug (and less likely to damage your GPIO pins!).

Sounds like you have a faulty LED though - can you pop an e-mail to support@pimoroni.com with your order number and we’ll arrange a replacement - sorry about that! :-(


#6

Got a replacement - thanks - but unfortunately this one has a problem, albeit a new and different problem. Backlight works fine, but it won’t display any text.

Have emailed support and popped it back in the post. Really want a working replacement as this will be ideal for my projects.


#7

Just so this doesn’t get lost can you drop another e-mail to support@pimoroni.com please? Sorry about that - we’re definitely having a few issues with DOT3k production, we’re working on it I promise!


#8

I’ve now received my third DOT3K.

This seems to also have the text problem; backlight works, joystick works, bargraph works. Text does not work; screen remains blank.

For example, running the example file from Github:
https://github.com/pimoroni/dot3k/blob/master/python/examples/basic/hello_world.py
…results in no text

Also running the joystick program:
https://github.com/pimoroni/dot3k/blob/master/python/examples/basic/joystick.py
…results in the backlights changing when the joystick is pressed, but no text.

Is there something I should do to absolutely confirm my setup before I send this back for a fourth one?

I have:

I really want this to work. What more can I do? Or is it simply a case of keep sending them back until I get lucky and get a working one?


#9

Hang on, hang on…

This is working on my Model A. Text works, everything works.

Not working on my Model B revision 1.

I’ll try it on a Model B+ later too.

Has something changed in the libraries which has knocked out Brev1 models?


Dot3k not working after apt-get upgrade to support Pi 2
#10

Solved.

Somehow the i2c & spi drivers / modules had got misconfigured on the SD card I used for the Model B rev 1. Reinstalling the modules / drivers / libraries did not do the trick.

Reverting back to a backup prior to installing DOT3K, and then installing the DOT3K modules / drivers / libraries as per https://github.com/pimoroni/dot3k/blob/master/python/README.md did the trick.

Still not quite sure how it managed to get corrupted, nor why a re-install over the top didn’t work, but the point is - it is working now.


#11

That’s good news! Glad you got it up and running in the end :-)


#12

The good news is we’ve tracked down our backlight issues with Display-O-Tron - it was caused by faulty right angle RGB LEDs. The worst thing is the fault was intermittent and units could happily pass our testing procedure and then go ahead and fail a couple of days later.

We’ve switched supplier for the part and are now seeing 100% success rate after extended test periods. We’ll be ramping up production again and getting Display-O-Tron out to our distributors too!

If you did get a faulty unit we’re really sorry - that sucks. Just get in touch if you need it replacing and we’ll be right on it. (E-mail support@pimoroni.com).


#13

I’m having a different kind of backlight problem: it doesn’t work at all. Attempting to use it results in errors like this:

$ sudo ./backlight.py
Traceback (most recent call last):
File “./backlight.py”, line 4, in
import dot3k.backlight as backlight
File “/usr/local/lib/python2.7/dist-packages/dot3k/backlight.py”, line 1, in
import sn3218, colorsys, math
File “/usr/local/lib/python2.7/dist-packages/sn3218.py”, line 17, in
i2c = SMBus(i2c_bus_id())
IOError: [Errno 2] No such file or directory

hello_world.py works just fine, however. This does not look like a hardware problem to me, but what I could be doing wrong, I don’t know.


#14

There a couple of things this could be, but the most likely is that i2c is not enabled.

Run this script, follow the steps, answer yes to enable i2c/spi and again when it asks if you want to reinstall libraries and see what happens:

curl -sS get.pimoroni.com/dot3k | bash

#15

I2C and SPI were enabled (and your script said so, too), but I let it reinstall libraries and, lo and behold, backlight started working.

Somewhat strange: this was a brand new Raspbian installation (I had done apt-get update && apt-get upgrade and installed the python stuff and nothing much else). Did your script install different versions of some libraries than what comes from Raspbian repositories or was I missing some relevant library or what did it change?


#16

The script makes sure that the Python libraries are completely reinstalled, from scratch, which makes sure the latest and greatest versions are installed. I think an older version of the sn3218 library didn’t handle olds Pi’s properly.


#17

Hmm. Looks like it installed a bunch of extra libraries, but which one(s) made the difference, I don’t know yet.

Incidentally, there’s a little bug in your script: it messes up WORKING_DIR if it’s ran as root without using sudo.
If you feel like fixing it, simplest would be something like
WORKING_DIR=${USER_HOME:=$HOME}/Pimoroni


#18

Oops, must correct myself, that fix doesn’t work. Try ${SUDO_USER:-root} in the above else-part instead.