Dot3K - no text, only 3 backlight LED's working. Help! [SOLVED]


#1

I’ve just received my shiny new Dot3k to work with my RPI2 B board, and a brand new installation of Raspbian with latest updates. I ran the curl scripts to install things, agreed to enable SPI etc when prompted, and also installed the extra packages for the demos. However, when running the demos, the basic hello world doesn’t error, but shows nothing on the display. The basic backlight demo runs without error, but only the left three backlight LED’s are working. I’ve then modded the backlight script to comment out the left/middle/right settings, so now it’s just calling backlight.rgb(255,255,255). When I run it, again, the three left backlight LED’s show white as expected, but the right half of the screen is unlit.

So, I’ve never seen any text, and the backlight test only appears to affect the left three screen LED’s. Faulty unit, or am I doing something wrong? I haven’t ventured any further, as I figure there’s no point until I get the basics working right.


#2

Sounds a lot like you’re running the Dot3K examples and libraries instead of the DotHAT ones. Can you post some of your code?

You should be looking in: /home/pi/Pimoroni/dot3k/dothat


#3

LOL, what a muppet. Yes, running the dothat backlight sample now provides me with rainbows, text and flashy white lights. Thanks for the insta-reply to my message - much appreciated! :)


#4

It’s okay. I was waiting for this very thing to happen and still wonder if I should have properly separated the two libraries. They have so much in common, though! ( as you found out! )