Dotstar LED pinout names?

I’ve just purchased a length of this and the solder points are marked as GND, SDI, CLKI and VCC. However I was expecting to see GND, 5V, CLK and DATA?

I’ve checked Adafruit’s PDF and there’s no mention of VCC, SDI or CLKI either. At a guess I’d say VCC is 5V, CLKI is CLK and SDI is DATA but I’d like to be sure.

Could anyone confirm if this is the case?

Any advice much appreciated.

Maybe this will help

Thanks for the reply @alphanumeric

Yep, that’s part of the PDF I mentioned. It doesn’t mention the names on the strip I have.

I think instead of i’s it’s actually 1 though. So the markings are SD1(0) and CLK1(0) either end. Therefore I’m pretty sure that I’ve got things the right way round but I’d just like absolute confirmation.

Found confirmation here,


Phew, I was right. :)

Good stuff, now you get to play with them. =)

Thanks! I’ve got them lit (yay!) via the picade’s x hat, but controlling them seems to be problematic. :(

I can feel another thread being started!

Sounds like your into the “how many in the string” etc coding. One thing that can mess you up is the first LED is 0, not 1. Blinkt and LED Shim wise its like that.

I’ve been trying to control them via the Picade Plasma Software that Pimoroni suggest. But although the software seems to install perfectly and the LEDs light up when I type ‘plasma’, I can’t seem to control them using the plasmactl command. :(

It’s really frustrating. I feel so close but my lack of knowledge of raspbian/coding etc is letting me down. It’s almost like I feel that the plasmactl command doesn’t exist or hasn’t been installed correctly.

Did you do the following ```

git clone https://github.com/pimoroni/plasma
cd plasma/daemon
sudo ./install

No, I pressed F4 to exit Emulation Station and dropped into the terminal. I then typed the following,

curl https://get.pimoroni.com/plasma | bash

I’ve not cloned anything before, would that have been better? It wasn’t mentioned in the install instructions page.

Have a look see here, under using plasma daemon

Thanks for that. :) I tried following the clone method but when I tried executing the line,
sudo ./install

it returns the line,
sudo: ./install: command not found

I don’t get it!? I checked the contents of the directory by typing ls and could see the install.sh executable, along with two other folders called ‘etc’ and ‘usr’

Any idea why the install.sh won’t execute?

I think that’s supposed to be :

sudo ./install.sh

Ahh, I see, you need the extension name. That did it, but it returns that there’s already a folder called that. In that case, I think I have everything installed correctly.

I’ve managed to track down the plasmactl program to a bin folder. But the command seems to be available system wide. I’ve not noticed before as I’ve been trying to execute the plasmactl AFTER I’ve run the plasma program itself. Running the actual plasma program itself seems to be the issue, in that I’m not sure it’s actually ‘finishing’? Basically, after running plasma I get the following,

2020-03-08 16:20:21.267363: Starting plasma in the foreground with framerate 30fps
2020-03-08 16:20:21.267372: Plasma input pipe: /tmp/plasma
Opening...
Open...
2020-03-08 16:20:21.361884: Loaded pattern file: /etc/plasma/default.png
_

That’s it, the LEDs light up. But the important thing (I think) is that underscore at the bottom… That’s all I get, I don’t get returned to the pi@retropie: prompt or placed in the folder I was in?? If I keep pressing return or try say the ls command, I just get the blinking underscore??

Any idea what this could mean?

No, I don’t know what that means? I’m busy right now but I’ll have a look see latter on. I don’t own a Picade and haven’t done anything with those light strips. Just Blinkt and the LED Shim.
I’ve run the Fan Shim service and that’s a run once and forget about it deal. Once installed and setup it runs on boot up all on its own. Same deal with the Track Ball Breakout Daemon, run it once and forget about it.

Thanks a lot for that, I’d really appreciate it. It’s driving me nuts!

I think it’s just supposed to ‘work’ too. So I can’t understand what could be causing the program to not initialise properly. Or that’s how it seems at least. Not going back to the correct prompt seems to suggest that.

The LED strip is the same ones (DotStar APA102) that Pimoroni use for their Plasma Buttons so I can’t see any reason why they wouldn’t just work the same.

EDIT: Disregard, Player X and Picade X are two different things.

Picade X Hat? I ask because it states the following on the GitHub page.

Using Plasma Daemon

Note: If you’re using Picade Player X you should edit daemon/etc/systemd/system/plasma.service and change the output device option from -o GPIO:14:15 to -o SERIAL:/dev/ttyACM0 . If you’re using Unicorn HAT or pHAT you should use -o WS281X:WS2812:18:0 .

And what is the exact plasmactl code your enetering?

Yep I noticed the plasma.service change. I’ve got a Picade X so I added the change to
-o SERIAL:/dev/ttyACM0
It didn’t make any difference unfortunately. :(

The commands I’ve been using are simple things like plasmactl 0 0 0 which should turn the LEDs black or plasmactl 255 255 255 all white etc. None of them work when the plasma program itself is activated. I just get that underscore and not a proper prompt.

What’s odd here is that I’d imagine the plasma program should be being started on boot up. But it isn’t. Hence why I have to manually enter plasma at which point it starts the LEDs blinking but doesn’t seem to initialise completely. ie, return me to a command prompt.

My Blinkt is listed as supported but I couldn’t get it to light up?
First I did the curl https://get.pimoroni.com/plasma | bash
Then the

git clone https://github.com/pimoroni/plasma
cd plasma/daemon
sudo ./install.sh

Then I did a sudo nano /plasma/daemon/etc/systemd/system/plasma.service

I tried the default 14:15 and changing it to 23:24 which is what the Blinkt uses but got noting? No error messages and no LED’s lit up?
plasmactl --list got me the list of patterns so I know the service is installed etc, just won’t work on my Blinkt as it is right now?
I don’t know what to tell you?

EDIT: I’m not getting stuck at the flashing underscore though.