Dotstar LED pinout names?

I think you already know this but there is an in and out end to the strip. If you try to feed your signal in from the wrong end nothing will happen. For example CI is CLK In and CO is CLK Out to the next LED. And DI is Data In and DO is Data OUT to the next LED. If you look at one of the cut lines between LED’s you should see what I mean.

Thanks so much for checking that out @alphanumeric

I got a Blinkt recently myself but only checked it worked via a different pi zero setup running desktop raspbian. I’m not sure myself how I would control it via the plasma plugin.

Yep I know about the in and out. I’ve got the wires running the correct direction, following the arrows. Always good to check those things though.

One thing I find suspect is that the initial install proceedure created the following folder structure

Notice the double plasma folders. The first plasma folder holds nothing except the subsequent plasma folder. I don’t understand that and wonder if it’s an error? Meaning that whatever script might be running is only expecting to see ‘one’ plasma folder in the structure. Hence a fail happening?

I have a home/pi/plasma/daemon folder, and the home/pi/Pimoroni/plasma/plasma folder?
One was likely from the bash install and the other the github clone? I’m not sure which one created which though? My bad that we probably didn’t need to do both? The plasma plasma one is almost certainly an error?
My Pimoroni folder also has my blinkt folder in it, which I believe was from running the bash curl install.
The home/pi/plasma/deamon is the one I think we are running the plasmactl from though?
Let me just say for the record that I have had a few rum & cokes tonight so I’ll have another better look at this tomorrow. ;)

1 Like

Yep I have another plasma directory in my parent structure too. Think it was made when I ran

git clone
cd plasma/daemon
sudo ./

It’s all a bit confusing isn’t it. I think the Pimoroni directory is the original though. I agree about the 2 plasma folders in it, they seem very suspicious. I’ve tried moving the plasma folder up one using the cp command, but my goodness I’m finding the command syntax in Raspbian confusing! I couldn’t work it out. I’ve tried,
cp -r plasma /Pimoroni/
Which in my mind should copy the plasma folder to the Pimoroni folder, but I just get a Permission denied message. I miss DOS…

Rum and coke sounds good! :) Thanks again for all the help. Maybe tomorrow a Pimoroni tech could chime in too and take pity on me!

EDIT: I managed to work out the copy syntax!
cp -r plasma /home/pi/Pimoroni

Still no joy though with the LEDs! Running plasma still doesn’t seem to execute completely as I’m not dropped back to a prompt. So can’t run plasmactl :(

Posted in your new thread. ;)

1 Like