EnviroPhat LEDs don't work


#1

After assembling the EnviroPhat, I tried the test program. Everything worked fine, only the leds did not blink, they remained black…I tried to control them directly via GPIO 4, this did work, but only 2 or 3 flashes, an they were black again. After a restart, the same Situation, 2 or 3 flashes, and then black again. Checking the voltage showed that the pin was dead when the leds did not light up.
Anny ideas what the Problem is?


#2

Is it possible GPIO4 is being controlled by a device tree overlay or something else? Have you tried testing on a clean Raspbian install to see if the LEDs behaved more adequately then?


#3

Thank you very much, it was the case. I had activated 1-wire support in the config.txt.
After removing that activation, everything works fine.


#4

Hi, thank you for the topic.

I had same problem with the leds and have fixed it by removing the following line from the file /boot/config.txt.

dtoverlay=w1-gpio

Or you can change the config through sudo raspi-config command.

5 Interfacing Options
    P7 1-Wire
        Would you like the one-wire interface to be enabled?
             No

I believe this must be a FAQ for enviro pHAT.

Many thanks