Explorer Hat Pro motor controller two won't go backwards


#1

Hi

Putting together STS-PI.

eh.motor.two.backwards(100) does nothing.

Forward works fine.

motor.one works perfect forward and backward.

Have switched motors and cables to isolate problem specifically to motor.two.backwards.

Any idea what to check? I have no soldering in project - just Explorer Hat Pro (brand new) plugged into Pi3 with cables to motors.

Have also noticed that any motor running plugged into motor.two is more noisey (but same speed) compared to when it is plugged into motor.one.

Cheers
Ben


#2

Do you have i2s audio enabled? Something like dtoverlay=hifiberry-dac in /boot/config.txt? It’s possible something else running on the motor pins could be interfering. BCM 19, 20, 21 and 26 drive the motors.


#3

Hi

Based on possible conflict with i2s audio as indicated in previous post, I reinstalled pi from scratch with nothing but i2c enabled.

Same problem - motor.two.backwards (100) does nothing.

Brand new Explorer Hat Pro faulty?

Cheers
Ben


#4

hum, not sure, possibly. Please contact support@pimoroni.com and they’ll talk you through exchange procedure.