STS-Pi with pi zero - motor problems - help required


#1

I’ve just put together the STS-Pi using a pi zero and explorer pHAT , which is the first time that I’ve tried controlling motors with a pi.

Everything working, except for one of the motor controls (Motor 1) on the Explorer pHAT. I can only get it to turn one way.

The “ eh.motor.one.forwards” command doesn’t seem to have any effect, whilst “eh.motor.one.backwards”is fine. I’ve double checked my soldering and the connections look fine (checking BCM19 and BCM20 in particular - does one control forward and one back?).

Any suggestions on what could be the problem? Is there a way to check that the pins on the explorer pHAT are working as they should?


#2

yes, one pin controls moving forward and one moving backwards.

Have you tried swapping the motors to see if the same outputs are playing up, as opposed to the motor moved to alternative pair of pins?


#3

I’ve tried swapping the motors and it is definitely the motor one forwards output that isn’t working. Do you know which pin it would be?


#4

you posted the correct pin number in your earlier post, but for (nearly) all your pinout needs you can consult http://pinout.xyz


#5

Thanks, but which of BCM19 and BCM20 is forward?


#6

BCM19, though the functions you are calling do act on both, so I would verify your soldering - both on the Pi header and the two pHAT headers - for both pins.