Explorer HAT Pro - Touch pads don't seem to be working

Hi,

I recently bought an Explorer HAT Pro for my Raspberry Pi 3 Model 3B+. I first installed the Explorer HAT with the “curl https://get.pimoroni.com/explorerhat | bash” command. To make sure that the Explorer HAT is installed and works correctly, I ran the “test.py” program, that is located at “cd ~/Pimoroni/explorerhat/examples”.
But then I got the following error message:

Exception ignored in: <function Cap1xxx.del at 0x764f29b8>
Traceback (most recent call last):
File “/usr/local/lib/python3.9/dist-packages/cap1xxx.py”, line 530, in del
self.stop_watching()
File “/usr/local/lib/python3.9/dist-packages/cap1xxx.py”, line 413, in stop_watching
if not self.alert_pin == -1:
AttributeError: ‘Cap1208’ object has no attribute ‘alert_pin’
Traceback (most recent call last):
File “”, line 1, in
File “/usr/local/lib/python3.9/dist-packages/explorerhat/pins.py”, line 98, in handler
return self._do(name, *args, **kwargs)
File “/usr/local/lib/python3.9/dist-packages/explorerhat/pins.py”, line 117, in _do
_results[node] = handler(*args, **kwargs)
File “/usr/local/lib/python3.9/dist-packages/explorerhat/init.py”, line 736, in is_pressed
raise RuntimeError(“Touch is unavailable, check your pHAT/HAT and/or connections!”)
RuntimeError: Touch is unavailable, check your pHAT/HAT and/or connections!

So touch seems to unavailable. By trying commands such as “explorerhat.touch.is_pressed()”, I get the same error message as above.

I also tested the lights with commands like “explorerhat.light.on()” and they seem to working correctly.

Since I wasn’t able to find anything helpful regarding my problem, I was hoping if someone in this forum could help me.

Thanks in advance for any pointers and guided advises you may be able to provide.

Did you have anything connected and setup on the GPIO Header previous to this?
Try running
python3 -m pip install --upgrade explorerhat

No, I never connected anything on the GPIO Header before. The Explorer Hat Pro was my first.
I also tried running the command and get the following result:

Looking in indexes: Simple index, piwheels - Simple index
Requirement already satisfied: explorerhat in /usr/local/lib/python3.9/dist-packages (0.5.1)
Collecting explorerhat
Using cached https ://www.piwheels.org/simple/explorerhat/ExplorerHAT-0.5.1-py3-none-any.whl (14 kB)
Using cached https ://www.piwheels.org/simple/explorerhat/ExplorerHAT-0.5.0-py3-none-any.whl (14 kB)
Requirement already satisfied: cap1xxx>=0.1.4 in /usr/local/lib/python3.9/dist-packages (from explorerhat) (0.1.4)
Requirement already satisfied: RPi.GPIO in /usr/lib/python3/dist-packages (from cap1xxx>=0.1.4->explorerhat) (0.7.0)

The command didn’t seem to help either, since I still get the the same error message as before.
I also tried connecting the Explorer Hat Pro to my Raspberry Pi Model 3B, to see if it works there, but sadly I get the same result.