(SOLVED) Problem with Explorer HAT Pro

My Explore HAT Pro will work fine on my Pi Zero but is not detected when attached to my Pi 3A+.
I have tried reinstalling the OS and python libraries etc to no avail.
I have also used the SD card from the Zero on the Pi 3 and no joy.
Does anyone have any other ideas on what the problem could be?

Can you elaborate on the “not detected”?
Do you get any error messages etc?

The error I get is:

Traceback (most recent call last):
** File “/home/steve/Pimoroni/explorerhat/examples/test.py”, line 26, in **
** explorerhat.touch.pressed(ohai)**
** File “/usr/local/lib/python3.9/dist-packages/explorerhat/pins.py”, line 98, in handler**
** return self._do(name, args, kwargs)
** File “/usr/local/lib/python3.9/dist-packages/explorerhat/pins.py”, line 117, in _do
** _results[node] = handler(args, kwargs)
** File “/usr/local/lib/python3.9/dist-packages/explorerhat/init.py”, line 748, in pressed
** raise RuntimeError(“Touch is unavailable, check your pHAT/HAT and/or connections!”)**
RuntimeError: Touch is unavailable, check your pHAT/HAT and/or connections!

i2cdetect -y 1 on the pi Zero gives 2 addresses 48 & 28, on the Pi 3A it shows no addresses.ls

Did you solder the header onto the 3A yourself? Might want to double-check the joints.

The 3A comes with the header pre soldered. I do believe the Zero is the only Pi model that is available without a GPIO header already attached.

It’s not a bad idea to have a look see anyway.

Near as I can tell the capacitive touch is via i2c.
The pinout page shows 0x28: cap1208.
I have no idea why that would be an issue on a 3A versus a Zero?

Obviously its an i2c issue though. Has this 3A been used prior to this?

EDIT: I’d give the solder pads on the header a good look see. Just to make sure something isn’t shorting one of the i2c pins to ground or something?

Cheers, I will have a look and see if there is anything obvious.

Everything looks OK and my other HATs and devices that use i2c are working with the Zero and the 3A.

Ahh, can never remember which Pi’s always come presoldered and which ones don’t.

I’ve bought and used quite a few 3A’s over the years, that’s why I know they come with a header. ;)

Running out of things to check? Have to ask the obvious, Explorer Hat firmly attached to the GPIO Header?

Also, does the 3A have a heatsink on the SOC?
If yes, make sure its not shorting / touching anything on the bottom side of the hat.

Yes, firmly attached, I have tried with the HAT screwed down and just pushed on, no heatsink.
Thanks for taking the time to help.
I guess I will just use the Explorer HAT on the Zero, although it is useful to be able to swap things around on some projects.
When 1 of my pi 5s is freed up I will try on that.

I’ve swapped a few hats around over the years, and not come across an issue like this?

Have you tried doing a fresh, from the bottom up, install on the 3A?
Pi OS then the hat software?

Just tried that and no joy, but it gave me another avenue to investigate. I had been SSHing into the Pi3, this time I used the GUI and noticed an under voltage warning, so I will get a better PSU and try that.

I for the most part use the Official Pi Power Supplies. The ones that aren’t, are over ratted current wise, for the hardware they are powering. A couple of 5V 4A, and one 5V 10A, regulated switching power supply.

What usually happens is the supply reduces it’s output voltage to stop an over current event. You get an under voltage warning. But in reality, its due to the current rating of the supply not being enough for the load its trying to power. And “chargers” are a no no, IMHO. They more often than not, don’t supply a nice clean 5V.

1 Like

I left this for a couple of weeks as I did not seem to be getting anywhere. So just tried the hat on the Pi3 againn and it is almost working, everything is OK except motor 2 will not run in reverse, although as before everything works 100% on the zero.

Weird that the one motor won’t run in reverse? If it goes forward you would think all the connections are good?

I’m currently tinkering with an Inventor 2040W and a couple of Micro Metal Gear Motors with encoders.
I have a couple of Explorer pHats on Pi Zero’s. Haven’t touched them in ages though.

Happy to say all seems to be sorted now.
I put a booster header on the Pi3A+ and attached the Explorer hat Pro and now all is working as it should.

1 Like