Fan Shim will not allow RPI4 to boot [SOLVED]

So I had setup my Raspberry PI 4 and everything was fine. I received the fan shim and installed it and it seemed to be working. I booted several times. I have not had the opportunity to play with it so it has been sitting on my desk. Today I decided I would experiment with it. I booted up the RPi without issues and did an apt full-upgrade now I can not get the RPI to boot if the fan shim is attached. It works just fine when it is removed. I am using the official 3A power supply and only attach the hdmi to see what is happening.

I goes into a continuous loop of not being able to read a ext4 partition.If I connect the fan shim after it is booted it seems to work ok.
Any ideas why it wont allow the RPi to boot?

Edit:
So it turns out it was a corrupt SD card. After only doing a SD card copy to a blank SD and then using that SD everything boots and runs as expected.
Its a bit of a mystery as to why it only was apparent if the shim was attached but that was the case.

Thats a weird one I must say? I have a 4B with a Fan Shim attached. Just yesterday I did an apt update apt upgrade, and a rpi-update to get the latest eprom boot code. No issues that I am aware of. I shut down and booted up after doing the above.
The only situation close to this posted here was a no boot as a result of the button on the fan shim being pressed on and held on by the case he had his Pi in.
The fan shim pinout is here.

I’m not sure what to look for or at to be honest? My Linux skills are pretty basic. Do you have the fan shim software installed? Fan control Daemon running? When you plug it into the running Pi does the fan work and or the LED light up?

Thanks for the reply. I did edit the post with the root cause. It was a corrupt SD card.

Still a weird one, but at least you figured it out.

Hello
I have just assembled the Fan shim and placed it upon a RPi4 with 2G memory running IMG of ubuntu 19.10 server with a standard ubuntu desktop on 32GB SD card, with official RPi Power Supply. Power on, fan comes on, runs with virtually no nosie or vibration detectable. As it boots up it gets to autoboot and then a UBOOT> prompt which then proceeds to fill with characters MC: across the screen. Keyboard drivers kernel assume not loaded at this point so no hardware drivers so keyboard doesn’t allow interrupt.

The push button which I assume disables the fan does not seem to have an effect, which fan still running

Remove the Fan Shim and the RPi4 boots up normally to ubuntu desktop. Has anybody experienced the same? I have repeated the process several times with Fan Shim pushed on to different heights to see if this makes a difference but appears not to.

Regards

1 Like

You should probably start a new thread on your issue. As this one is marked solved etc. You’ll have a better chance of good help with the proper title etc.
I will say thats a weird one? The button doesn’t turn the fan off, unless you set it up to do that manually. The fan shim pinout is posted above.

Same problem here. Brand new SD card, booting fine without Fan Shim mounted. As soon as Fan Shim is mounted, the RPi freezes in the U-Boot> prompt, detecting weird input chars.

(Ubuntu 19.10 64 bits)

Best guess is Ubuntu is doing something with or looking for something on the UART GPIO pins on boot up. Those two pins are where the Fan Shim LED is wired too and controlled from.

Hmm, disabling uart entirely in config.txt seems to have fixed the issue.

Thats good to hear. The Fan Shim LED is one of those addressable LED’s. It must be sending gibberish back over the UART lines, something like that.

Sadly, it appears not. The behavior is rather random … another pi 4 seems to be more stable. In the end i haven’t figured it out and moved to a raspbian 32bit image, since i would prefer using the fan shims.
Thanks for the support, i’ll keep an eye out for any possible fixes.