3.5" LCD won't work with Fan Shim

I have a Raspberry Pi 4 4gb with a 3.5" Kuman LCD touch screen. I am running a Raspiblitz Lightning node on the setup and just received a Fan Shim to install on it. For some reason, with both the Fan Shim and LCD screen installed, the system will not boot. The LCD will turn on along with the fan and randomly display code without proceeding anywhere. Ends up stopping on a blank screen with a little dash in the top left corner.

If I remove the LCD and keep the fan installed, the system will boot and operate as normal. If I remove the fan and install the LCD, the system boots and operates as normal. With them both installed, no luck. Any ideas which part could be causing the issue? Power supply is the Cana Kit 5.1v, 3.5A

1 Like

Its more than likely a GPIO Pin conflict. They both must be “trying” to use one or more of the same GPIO pins. The Pinout for the Fan Shim is here.

Thanks for the reply. What would be the fix for that? This is a known combination of parts that a lot of people have used together.

If people are already using the two together, I must be wrong? Don’t take this the wrong way but maybe ask somebody that has that combination working how they did it?
I have a Fan Shim but I’m not using a GPIO attached screen. I have a Blinkt pulled in on top of the Fan Shim. They don’t share any GPIO pins other than power and ground.

I have been in contact with everyone in that group as well. None of them understand why it isn’t working. I tried ordering a new screen to see if that was the issue, same problem with the new screen. I then thought I would test the combination out on the Pi 3b that I have, works fine with both installed on the Pi 3b. I am starting to think it is a problem either with my specific Pi 4 4gb. Only thing I can think to do is order a new Pi 4gb to test. Pretty frustrating.

Did you try that same Micro SD card used in the Pi 4B (that doesn’t work) in the 3B?
If the that card works fine in the 3B with the Fan Shim and display attached, that does indicate that its a hardware issue. To me it does anyway.
Are you running Buster on the 3B?

I tried it with the card from the Pi 4 in the Pi 3 and it worked. I also tested a new card on the Pi 4 with a fresh install and had the same problem. Currently I am running the Raspiblitz program that is built on Raspbian. I am honestly not sure what Buster is.

Buster is the current version of Raspbian and the only version of Raspbian that will boot on a Pi 4. It will boot on any model Pi but any previous version like Stretch, will not boot on a Pi 4.

I’m leaning towards this being a hardware issue. I don’t know how you prove it though? At this point its getting to be above my skill level.

It would definitely be Buster then. It boots and operates as normal when both the screen and fan shim aren’t installed at the same time. Raspiblitz version 1.3 added Pi 4 support so I bet that is when they upgraded to Buster.

I ordered the Cana Kit from Amazon a little over a week ago so I am still within the return period. I requested an exchange so they are sending out a new one, I can test it and return the old one after. I will keep you updated what I find out. I appreciate the input.

I am to having issues. I took the LCD off and was able to SSH in and all is fine, temps are right at 50 (Pi 4)

I am running Raspiblitz 1.3

So I turn it on it looks to boot normally and then mine starts blinking over and over and it looks like its running its boot sequence. I love this little thing, its a great idea but it was sooo nice to have that LCD screen on to peak at it rather than log in :(

I may run this without FanShim and go back to my USB 5v fan, was quiet and kept temps in the high 30s, just so big :(

I am willing to entertain ideas on this though.

I got a new Pi 4 in the mail, swapped everything over, turned it on and the problem is still there. LCD don’t work with the fan shim like it should. Now that there is someone else here with the same issue, I am starting to have doubts that this combination was ever tested on the Pi 4. It seems there is a compatibility issue using the fan shim and LCD together on the Pi 4.

I would say it might be the fan as that is the only part that I haven’t swapped out BUT the fan shim and LCD work fine together on my Pi 3b. I have a real good feeling ordering another fan shim will be a further waste of money.

Just a FYI post. You can install the Fan Shim and it will work (sort of) without any software. The fan will just run continuously when the Pi has power. The LED will be off. The button still works, my Pi 4 boots up and shuts down when I press it. There is a config.txt edit required to do the shut down.

I have the same issue that Silarous described. The only difference is that I am using a PI4 2GB instead of a Pi4 4GB.

I noticed that the fan (HW/SW) does not allow my board to boot. It gets stock somewhere. The only way to allow the board to boot is to remove the fan :-/.

I compare the pins used by the fan 5, 8, 10, 11 (Button), 12 https://pinout.xyz/pinout/fan_shim#

vs the pins used by the LCD https://www.waveshare.com/3.5inch-RPi-LCD-A.htm
As you can see the pin that seams to bee the issue is pin 11 (TP_IRQ).

I don’t need the button on the fan. Is there any way to completely disabled this circuit to prevent any interference with the LCD

Some careful hunting down and cutting of the PCB trace for this button should suffice, and I suspect it’s even possible to re-route to another pin if you’ve got any soldering tools and wire.

You could carefully drill out that pad on the fan shim so the hole is so big it doesn’t touch the GPIO pin. Somebody in another thread stated they just cut those two last pads off of the fan shim circuit board. The fan will just run continuously. You can no longer turn it on and off my temperature.
That button also connects to the “wake” pin. Thats the pin I’m using to turn my Pi on and off. GPIO 3. Phil can confirm it, but the other pin is I “think” the pin the python code poles to see if its pressed or not.

If look at the fan shim circuit board, the round pad on the end opposite the one mounting hole is GPIO 17, physical pin 11.
If you look close you’ll see a circuit track / trace going out the bottom of that pad and then turning towards the switch. If you take an exacto knife and carefully cut that track so there is a thin gap in it. That pad will no longer be connected to the switch.
Like you’d do to change the i2c address on a breakout board.

If that is the only track going to that pad, I would think that “should” do it.
I have a fan shim, I don’t have that display though.

Where I have the white line in this picture. If you carefully scrape the black paint off you should see a cooper track under it going down and then left. Cut that track so there is a gap in it. Do this at your own risk.


I made the whole bigger (Pin 11) , which destroy the copper trace. There is not any difference, beside that push botton is gone, still not able to have the LCD working :-/.

I am lost :-O
These is what I tried:

  1. LCD only (drivers and services) without any changes on SW -> LCD works
  2. Fan (drivers and services) only without any changes on SW -> Fan works
  3. LCD with Fan without any changes on SW -> Board does not boot

I dont have a clue what is going on. Pin 11 is the only pin that is actually use by both devices (LCD and Fan). The connectivity on the fan side is gone since I made the whole bigger and there isnt any contact with the pin.

Is it maybe because the fan or is draining too much current that affect the LCD?

Any ideas what else to try?

To be honest I was doubtful it was the button doing it, but stranger things have happened. If its wired up the way I think it is, it only grounds that pin when and while pressed. If you don’t have you finger on the button that pin should just be floating an open circuit. Anything else that wants to use it should be able to use it.